[1/5] gnu: gtk+: Add "bin" output.

Message ID 20160806104616.13089-1-iyzsong@gmail.com
State New
Headers

Commit Message

宋文武 Aug. 6, 2016, 10:46 a.m. UTC
  * gnu/packages/gtk.scm (gtk+)[outputs]: New field.
---
 gnu/packages/gtk.scm | 1 +
 1 file changed, 1 insertion(+)
  

Comments

Leo Famulari Aug. 14, 2016, 2:21 a.m. UTC | #1
On Sat, Aug 06, 2016 at 06:46:12PM +0800, 宋文武 wrote:
> * gnu/packages/gtk.scm (gtk+)[outputs]: New field.
> ---
>  gnu/packages/gtk.scm | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> index 21365b9..5c42053 100644
> --- a/gnu/packages/gtk.scm
> +++ b/gnu/packages/gtk.scm
> @@ -624,6 +624,7 @@ application suites.")
>               (base32
>                "157nh9gg0p2avw765hrnkvr8lsh2w811397yxgjv6q5j4fzz6d1q"))
>              (patches (search-patches "gtk3-respect-GUIX_GTK3_PATH.patch"))))
> +   (outputs '("out" "bin" "doc"))
>     (propagated-inputs
>      `(("at-spi2-atk" ,at-spi2-atk)
>        ("atk" ,atk)

What effect does this have?

Does Guix know to put something into the 'bin' output?
  
Eric Bavier Aug. 14, 2016, 2:51 a.m. UTC | #2
On Sat, 13 Aug 2016 22:21:53 -0400
Leo Famulari <leo@famulari.name> wrote:

> On Sat, Aug 06, 2016 at 06:46:12PM +0800, 宋文武 wrote:
> > * gnu/packages/gtk.scm (gtk+)[outputs]: New field.
> > ---
> >  gnu/packages/gtk.scm | 1 +
> >  1 file changed, 1 insertion(+)
> > 
> > diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> > index 21365b9..5c42053 100644
> > --- a/gnu/packages/gtk.scm
> > +++ b/gnu/packages/gtk.scm
> > @@ -624,6 +624,7 @@ application suites.")
> >               (base32
> >                "157nh9gg0p2avw765hrnkvr8lsh2w811397yxgjv6q5j4fzz6d1q"))
> >              (patches (search-patches "gtk3-respect-GUIX_GTK3_PATH.patch"))))
> > +   (outputs '("out" "bin" "doc"))
> >     (propagated-inputs
> >      `(("at-spi2-atk" ,at-spi2-atk)
> >        ("atk" ,atk)  
> 
> What effect does this have?
> 
> Does Guix know to put something into the 'bin' output?

Yes, the gnu-build-system will automatically pass '--bindir' to
'configure' if a "bin" output is present.

However, should these outputs not instead be added to the 'gtk+-2'
package that 'gtk+' inherits from?

`~Eric
  
=?utf-8?B?5a6L5paH5q2m?= Aug. 14, 2016, 6:21 a.m. UTC | #3
Eric Bavier <ericbavier@openmailbox.org> writes:

> On Sat, 13 Aug 2016 22:21:53 -0400
> Leo Famulari <leo@famulari.name> wrote:
>
>> On Sat, Aug 06, 2016 at 06:46:12PM +0800, 宋文武 wrote:
>> > * gnu/packages/gtk.scm (gtk+)[outputs]: New field.
>> > ---
>> >  gnu/packages/gtk.scm | 1 +
>> >  1 file changed, 1 insertion(+)
>> > 
>> > diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
>> > index 21365b9..5c42053 100644
>> > --- a/gnu/packages/gtk.scm
>> > +++ b/gnu/packages/gtk.scm
>> > @@ -624,6 +624,7 @@ application suites.")
>> >               (base32
>> >                "157nh9gg0p2avw765hrnkvr8lsh2w811397yxgjv6q5j4fzz6d1q"))
>> >              (patches (search-patches "gtk3-respect-GUIX_GTK3_PATH.patch"))))
>> > +   (outputs '("out" "bin" "doc"))
>> >     (propagated-inputs
>> >      `(("at-spi2-atk" ,at-spi2-atk)
>> >        ("atk" ,atk)  
>> 
>> What effect does this have?
>> 
>> Does Guix know to put something into the 'bin' output?
>
> Yes, the gnu-build-system will automatically pass '--bindir' to
> 'configure' if a "bin" output is present.

Yes, this will put 'gtk-update-icon-cache', 'gtk-encode-symbolic-svg',
'gtk3-dome', etc in the "bin" output.

>
> However, should these outputs not instead be added to the 'gtk+-2'
> package that 'gtk+' inherits from?

Yeah, but do it to 'gtk+-2' will fail with cycle references between
its "bin" and "out".  So I just leave it untouched.
  
=?utf-8?B?5a6L5paH5q2m?= Aug. 23, 2016, 12:11 p.m. UTC | #4
Hi, I pushed those patches and the results of a run of
gnome updater into core-updates.
  
Ludovic Courtès Aug. 29, 2016, 3:56 p.m. UTC | #5
宋文武 <iyzsong@gmail.com> skribis:

> * gnu/packages/gtk.scm (gtk+)[outputs]: New field.
> ---
>  gnu/packages/gtk.scm | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> index 21365b9..5c42053 100644
> --- a/gnu/packages/gtk.scm
> +++ b/gnu/packages/gtk.scm
> @@ -624,6 +624,7 @@ application suites.")
>               (base32
>                "157nh9gg0p2avw765hrnkvr8lsh2w811397yxgjv6q5j4fzz6d1q"))
>              (patches (search-patches "gtk3-respect-GUIX_GTK3_PATH.patch"))))
> +   (outputs '("out" "bin" "doc"))

I suppose the intent was to reduce the closure size; do you have
figures?  I like to put them as a comment next to the ‘outputs’ field.

Thanks!

Ludo’.
  

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 21365b9..5c42053 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -624,6 +624,7 @@  application suites.")
              (base32
               "157nh9gg0p2avw765hrnkvr8lsh2w811397yxgjv6q5j4fzz6d1q"))
             (patches (search-patches "gtk3-respect-GUIX_GTK3_PATH.patch"))))
+   (outputs '("out" "bin" "doc"))
    (propagated-inputs
     `(("at-spi2-atk" ,at-spi2-atk)
       ("atk" ,atk)