gnu: libextractor: Update inputs.
Commit Message
Hello,
On Wed, Aug 03, 2016 at 01:52:49PM +0000, ng0 wrote:
> This patch updates (input) of libextractor, adding some optional
> dependencies we packaged already.
thanks! I could not resist to order the inputs alphabetically, updated
patch attached...
Unfortunately, it fails a test for me:
PASS: test_zip
Did not get expected meta data of type 2 and format 1 with value `test.html' from plugin `archive'
Did not get expected meta data of type 2 and format 1 with value `test.jpg' from plugin `archive'
Did not get expected meta data of type 54 and format 1 with value `GNU tar format' from plugin `archive'
FAIL: test_archive
...
=========================================
1 of 28 tests failed
Please report to bug-libextractor@gnu.org
=========================================
Besides doing as the test suggests, a first measure could be to not
add libarchive for the time being :-)
Andreas
From 1a16986771f1c818e431ddf5077da775ff652e61 Mon Sep 17 00:00:00 2001
From: ng0 <ng0@we.make.ritual.n0.is>
Date: Wed, 3 Aug 2016 13:42:27 +0000
Subject: [PATCH] gnu: libextractor: Add inputs.
* gnu/packages/gnunet.scm (libextractor)[inputs]: Add gtk+, libarchive,
libgsf, libmpeg2.
* [arguments](configure-flags): Add flag to configure with libltdl.
---
gnu/packages/gnunet.scm | 28 ++++++++++++++++------------
1 file changed, 16 insertions(+), 12 deletions(-)
Comments
Hi,
Andreas Enge <andreas@enge.fr> writes:
> Hello,
>
> On Wed, Aug 03, 2016 at 01:52:49PM +0000, ng0 wrote:
>> This patch updates (input) of libextractor, adding some optional
>> dependencies we packaged already.
>
> thanks! I could not resist to order the inputs alphabetically, updated
> patch attached...
>
> Unfortunately, it fails a test for me:
> PASS: test_zip
> Did not get expected meta data of type 2 and format 1 with value `test.html' from plugin `archive'
> Did not get expected meta data of type 2 and format 1 with value `test.jpg' from plugin `archive'
> Did not get expected meta data of type 54 and format 1 with value `GNU tar format' from plugin `archive'
> FAIL: test_archive
> ...
> =========================================
> 1 of 28 tests failed
> Please report to bug-libextractor@gnu.org
> =========================================
>
> Besides doing as the test suggests, a first measure could be to not
> add libarchive for the time being :-)
>
> Andreas
>
This is weird. I ran this 2 days ago with no failing tests.
I'll see if I had an update I did not post.
Thanks
> From 1a16986771f1c818e431ddf5077da775ff652e61 Mon Sep 17 00:00:00 2001
> From: ng0 <ng0@we.make.ritual.n0.is>
> Date: Wed, 3 Aug 2016 13:42:27 +0000
> Subject: [PATCH] gnu: libextractor: Add inputs.
>
> * gnu/packages/gnunet.scm (libextractor)[inputs]: Add gtk+, libarchive,
> libgsf, libmpeg2.
> * [arguments](configure-flags): Add flag to configure with libltdl.
> ---
> gnu/packages/gnunet.scm | 28 ++++++++++++++++------------
> 1 file changed, 16 insertions(+), 12 deletions(-)
>
> diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
> index 4d888bd..bce12b3 100644
> --- a/gnu/packages/gnunet.scm
> +++ b/gnu/packages/gnunet.scm
> @@ -50,6 +50,7 @@
> #:use-module (gnu packages tls)
> #:use-module (gnu packages video)
> #:use-module (gnu packages xiph)
> + #:use-module (gnu packages backup)
> #:use-module ((guix licenses) #:prefix license:)
> #:use-module (guix packages)
> #:use-module (guix download)
> @@ -81,17 +82,12 @@
> ;; FIXME:
> ;; The following dependencies are all optional, but should be
> ;; available for maximum coverage:
> - ;; * libarchive
> - ;; * libgif (giflib)
> - ;; * libgtk+ >= 3.0.0 (may probably drop glib then as a propagated input of
> - ;; gtk)
> - ;; * libgsf
> ;; * libmagic (file)
> - ;; * libmpeg2
> - ;; * libmp4v2
> - ;; * librpm
> - ;; * libsmf
> - ;; * libtidy
> + ;; * libmp4v2 ; package it
> + ;; * librpm ; package it
> + ;; * libsmf ; package it
> + ;; * libtidy ; package it
> + ;; * libgif (giflib) ; investigate failure
> (inputs
> `(("exiv2" ,exiv2)
> ("flac" ,flac)
> @@ -100,14 +96,22 @@
> ("glib" ,glib)
> ("gstreamer" ,gstreamer)
> ("gst-plugins-base" ,gst-plugins-base)
> + ("gtk+" ,gtk+)
> + ("libarchive" ,libarchive)
> + ("libgsf" ,libgsf)
> ("libjpeg" ,libjpeg)
> + ("libltdl" ,libltdl)
> + ("libmpeg2" ,libmpeg2)
> ("libogg" ,libogg)
> ("libtiff" ,libtiff)
> - ("libltdl" ,libltdl)
> ("libvorbis" ,libvorbis)
> ("zlib" ,zlib)))
> (native-inputs
> - `(("pkg-config" ,pkg-config)))
> + `(("pkg-config" ,pkg-config)))
> + (arguments
> + `(#:configure-flags
> + (list (string-append "--with-ltdl="
> + (assoc-ref %build-inputs "libltdl")))))
> (synopsis "Library to extract meta-data from media files")
> (description
> "GNU libextractor is a library for extracting metadata from files. It
> --
> 2.9.2
>
On Fri, Aug 05, 2016 at 08:42:46PM +0000, ng0 wrote:
> This is weird. I ran this 2 days ago with no failing tests.
> I'll see if I had an update I did not post.
This could also be a sign of non-determinism. As posted two days ago,
I had packages that failed on hydra, but built correctly locally.
Sometimes there are also race conditions between different tests;
adding "#:parallel-tests? #f" can be an option then.
Andreas
@@ -50,6 +50,7 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages video)
#:use-module (gnu packages xiph)
+ #:use-module (gnu packages backup)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -81,17 +82,12 @@
;; FIXME:
;; The following dependencies are all optional, but should be
;; available for maximum coverage:
- ;; * libarchive
- ;; * libgif (giflib)
- ;; * libgtk+ >= 3.0.0 (may probably drop glib then as a propagated input of
- ;; gtk)
- ;; * libgsf
;; * libmagic (file)
- ;; * libmpeg2
- ;; * libmp4v2
- ;; * librpm
- ;; * libsmf
- ;; * libtidy
+ ;; * libmp4v2 ; package it
+ ;; * librpm ; package it
+ ;; * libsmf ; package it
+ ;; * libtidy ; package it
+ ;; * libgif (giflib) ; investigate failure
(inputs
`(("exiv2" ,exiv2)
("flac" ,flac)
@@ -100,14 +96,22 @@
("glib" ,glib)
("gstreamer" ,gstreamer)
("gst-plugins-base" ,gst-plugins-base)
+ ("gtk+" ,gtk+)
+ ("libarchive" ,libarchive)
+ ("libgsf" ,libgsf)
("libjpeg" ,libjpeg)
+ ("libltdl" ,libltdl)
+ ("libmpeg2" ,libmpeg2)
("libogg" ,libogg)
("libtiff" ,libtiff)
- ("libltdl" ,libltdl)
("libvorbis" ,libvorbis)
("zlib" ,zlib)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--with-ltdl="
+ (assoc-ref %build-inputs "libltdl")))))
(synopsis "Library to extract meta-data from media files")
(description
"GNU libextractor is a library for extracting metadata from files. It