gnu: node: Update to 6.3.1

Message ID 20160805102835.27263-1-jlicht@fsfe.org
State New
Headers

Commit Message

Jelle Licht Aug. 5, 2016, 10:28 a.m. UTC
  * gnu/packages/node.scm (node): Update to 6.3.1.
---
 gnu/packages/node.scm | 35 ++++++++++++++++-------------------
 1 file changed, 16 insertions(+), 19 deletions(-)
  

Comments

Jelle Licht Aug. 5, 2016, 10:33 a.m. UTC | #1
Please disregard this patch,

I was a wee bit impatient with trying out git send-mail

- Jelle

2016-08-05 12:28 GMT+02:00 Jelle Licht <jlicht@fsfe.org>:

> * gnu/packages/node.scm (node): Update to 6.3.1.
> ---
>  gnu/packages/node.scm | 35 ++++++++++++++++-------------------
>  1 file changed, 16 insertions(+), 19 deletions(-)
>
> diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
> index 887ef93..f62555e 100644
> --- a/gnu/packages/node.scm
> +++ b/gnu/packages/node.scm
> @@ -25,6 +25,7 @@
>    #:use-module (guix derivations)
>    #:use-module (guix download)
>    #:use-module (guix build-system gnu)
> +  #:use-module (guix build utils)
>    #:use-module (gnu packages base)
>    #:use-module (gnu packages compression)
>    #:use-module (gnu packages gcc)
> @@ -37,14 +38,14 @@
>  (define-public node
>    (package
>      (name "node")
> -    (version "6.0.0")
> +    (version "6.3.1")
>      (source (origin
>                (method url-fetch)
>                (uri (string-append "http://nodejs.org/dist/v" version
>                                    "/node-v" version ".tar.gz"))
>                (sha256
>                 (base32
> -                "0cpw7ng193jgfbw2g1fd0kcglmjjkb
> j4xb89g00z8zz0lj0nvdbd"))))
> +                "1xh883fbhyhgna1vi8xmd6klg4r186
> lb1h1xr08hn89wy7f48q9z"))))
>      (build-system gnu-build-system)
>      (arguments
>       ;; TODO: Package http_parser and add --shared-http-parser.
> @@ -78,7 +79,10 @@
>               ;; FIXME: These tests fail in the build container, but they
> don't
>               ;; seem to be indicative of real problems in practice.
>               (for-each delete-file
> -                       '("test/parallel/test-cluster-master-error.js"
> +                       '("test/parallel/test-https-
> connect-address-family.js"
> +                         "test/parallel/test-tls-
> connect-address-family.js"
> +                         "test/parallel/test-dgram-membership.js"
> +                         "test/parallel/test-cluster-master-error.js"
>                           "test/parallel/test-cluster-master-kill.js"
>                           "test/parallel/test-npm-install.js"
>                           "test/parallel/test-stdout-close-unref.js"
> @@ -101,22 +105,15 @@
>                               (string-append (assoc-ref inputs "python")
>                                              "/bin/python")
>                               "configure" flags)))))
> -         (replace 'patch-shebangs
> -           (lambda* (#:key outputs #:allow-other-keys #:rest all)
> -             ;; Work around <http://bugs.gnu.org/23723>.
> -             (let* ((patch  (assoc-ref %standard-phases 'patch-shebangs))
> -                    (npm    (string-append (assoc-ref outputs "out")
> -                                           "/bin/npm"))
> -                    (target (readlink npm)))
> -               (and (apply patch all)
> -                    (with-directory-excursion (dirname npm)
> -                      ;; Turn NPM into a symlink to TARGET again, which
> 'npm'
> -                      ;; relies on for the resolution of relative file
> names
> -                      ;; in JS files.
> -                      (delete-file target)
> -                      (rename-file npm target)
> -                      (symlink target npm)
> -                      #t))))))))
> +         (add-after 'patch-shebangs 'patch-npm-shebang
> +                (lambda* (#:key outputs #:allow-other-keys)
> +                  (let* ((bindir (string-append (assoc-ref outputs "out")
> +                                                "/bin"))
> +                         (npm    (string-append bindir "/npm"))
> +                         (target (readlink npm)))
> +                    (with-directory-excursion bindir
> +                      (patch-shebang target (list bindir))
> +                      #t)))))))
>      (native-inputs
>       `(("python" ,python-2)
>         ("perl" ,perl)
> --
> 2.9.2
>
>
  

Patch

diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 887ef93..f62555e 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -25,6 +25,7 @@ 
   #:use-module (guix derivations)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build utils)
   #:use-module (gnu packages base)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages gcc)
@@ -37,14 +38,14 @@ 
 (define-public node
   (package
     (name "node")
-    (version "6.0.0")
+    (version "6.3.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://nodejs.org/dist/v" version
                                   "/node-v" version ".tar.gz"))
               (sha256
                (base32
-                "0cpw7ng193jgfbw2g1fd0kcglmjjkbj4xb89g00z8zz0lj0nvdbd"))))
+                "1xh883fbhyhgna1vi8xmd6klg4r186lb1h1xr08hn89wy7f48q9z"))))
     (build-system gnu-build-system)
     (arguments
      ;; TODO: Package http_parser and add --shared-http-parser.
@@ -78,7 +79,10 @@ 
              ;; FIXME: These tests fail in the build container, but they don't
              ;; seem to be indicative of real problems in practice.
              (for-each delete-file
-                       '("test/parallel/test-cluster-master-error.js"
+                       '("test/parallel/test-https-connect-address-family.js"
+                         "test/parallel/test-tls-connect-address-family.js"
+                         "test/parallel/test-dgram-membership.js"
+                         "test/parallel/test-cluster-master-error.js"
                          "test/parallel/test-cluster-master-kill.js"
                          "test/parallel/test-npm-install.js"
                          "test/parallel/test-stdout-close-unref.js"
@@ -101,22 +105,15 @@ 
                              (string-append (assoc-ref inputs "python")
                                             "/bin/python")
                              "configure" flags)))))
-         (replace 'patch-shebangs
-           (lambda* (#:key outputs #:allow-other-keys #:rest all)
-             ;; Work around <http://bugs.gnu.org/23723>.
-             (let* ((patch  (assoc-ref %standard-phases 'patch-shebangs))
-                    (npm    (string-append (assoc-ref outputs "out")
-                                           "/bin/npm"))
-                    (target (readlink npm)))
-               (and (apply patch all)
-                    (with-directory-excursion (dirname npm)
-                      ;; Turn NPM into a symlink to TARGET again, which 'npm'
-                      ;; relies on for the resolution of relative file names
-                      ;; in JS files.
-                      (delete-file target)
-                      (rename-file npm target)
-                      (symlink target npm)
-                      #t))))))))
+         (add-after 'patch-shebangs 'patch-npm-shebang
+                (lambda* (#:key outputs #:allow-other-keys)
+                  (let* ((bindir (string-append (assoc-ref outputs "out")
+                                                "/bin"))
+                         (npm    (string-append bindir "/npm"))
+                         (target (readlink npm)))
+                    (with-directory-excursion bindir
+                      (patch-shebang target (list bindir))
+                      #t)))))))
     (native-inputs
      `(("python" ,python-2)
        ("perl" ,perl)