gnu: libpsl: Update to 0.14.0.
Commit Message
* gnu/packages/web.scm (libpsl): Update to 0.14.0.
---
gnu/packages/web.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
Comments
Hello, Tobias,
On Thu, Aug 04, 2016 at 03:32:32AM +0200, Tobias Geerinckx-Rice wrote:
> * gnu/packages/web.scm (libpsl): Update to 0.14.0.
> - (version "0.13.0")
> + (version "0.14.0")
> - "0afn2c4s2m65xifa5sfdll0s2gyqbh2q9k9nq4nsmx1b6c2i3i7x"))))
> + "1yrfkwjw5b9y9qb4xqw7g0hk0wdscay701c1wkg8fp7lxny99iz8"))))
I think you can push such trivial changes without asking on the list, assuming
that the package still builds, and maybe also after testing one or two
packages depending on it. If you want to be perfect, you could also observe
how it then behaves on the next hydra evaluation and whether it breaks other
packages.
Andreas
Andreas,
On 04/08/16 10:09, Andreas Enge wrote:
> I think you can push such trivial changes without asking on the list
Oh, I absolutely agree, but then HACKING reads:
Non-trivial patches should always be posted to
guix-devel@gnu.org (trivial patches include fixing typos, etc.)
Choosing typos as an example seemed oddly specific and deliberate to me,
not on the same level as even minor revision bumps.
Glad to hear I was being overly cautious :-)
Kind regards,
T G-R
@@ -14,6 +14,7 @@
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -453,7 +454,7 @@ for efficient socket-like bidirectional reliable communication channels.")
(define-public libpsl
(package
(name "libpsl")
- (version "0.13.0")
+ (version "0.14.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/rockdaboot/libpsl/"
@@ -461,7 +462,7 @@ for efficient socket-like bidirectional reliable communication channels.")
"/libpsl-" version ".tar.gz"))
(sha256
(base32
- "0afn2c4s2m65xifa5sfdll0s2gyqbh2q9k9nq4nsmx1b6c2i3i7x"))))
+ "1yrfkwjw5b9y9qb4xqw7g0hk0wdscay701c1wkg8fp7lxny99iz8"))))
(build-system gnu-build-system)
(inputs
`(("icu4c" ,icu4c)