Ecl

Message ID 20160731132510.2d368b95@uwaterloo.ca
State New
Headers

Commit Message

Andy Patterson July 31, 2016, 5:25 p.m. UTC
  On Sun, 31 Jul 2016 12:00:25 +0200
Andreas Enge <andreas@enge.fr> wrote:

> Yet another package which fails on all architectures:
>    http://hydra.gnu.org:3000/build/1313690
> If someone is interested in it, please have a look.

This patch should address the issue. It's for core-updates. I've tested
it locally.

Andy
  

Comments

Andreas Enge July 31, 2016, 6:13 p.m. UTC | #1
On Sun, Jul 31, 2016 at 01:25:10PM -0400, Andy Patterson wrote:
> This patch should address the issue. It's for core-updates. I've tested
> it locally.

Just pushed, thanks a lot!

Andreas
  

Patch

From 3306dfad4dbb2288a6a689596e3a14abac5a093b Mon Sep 17 00:00:00 2001
From: Andy Patterson <ajpatter@uwaterloo.ca>
Date: Sun, 31 Jul 2016 13:21:07 -0400
Subject: [PATCH] gnu: ecl: Use "kernel-headers" instead of "linux-headers" to
 designate input.

* gnu/packages/lisp.scm (ecl)[arguments]: Use "kernel-headers" as the
identifier for an input.

This is a follow-up to commit 55de892b435657f82a25c6499174d09b4a680f15.
---
 gnu/packages/lisp.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 5c0df4e..1772780 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -148,7 +148,7 @@  interface to the Tk widget system.")
                  `("CPATH" suffix
                    ,(map (lambda (lib)
                            (input-path lib "/include"))
-                         `("linux-headers" ,@libraries)))
+                         `("kernel-headers" ,@libraries)))
                  `("LIBRARY_PATH" suffix ,library-directories)
                  `("LD_LIBRARY_PATH" suffix ,library-directories)))))
          (add-after 'wrap 'check (assoc-ref %standard-phases 'check)))))
-- 
2.9.2