gnu: wxwidgets-2: Update to upstream's re-release of 2.8.12.

Message ID 20160722135948.23541-1-jlicht@fsfe.org
State New
Headers

Commit Message

Jelle Licht July 22, 2016, 1:59 p.m. UTC
  * gnu/packages/wxwidgets.scm (wxwidgets-2): Add a guix revision number
  to the version scheme of wxwidgets-2 to force an update.
---
 gnu/packages/wxwidgets.scm | 54 +++++++++++++++++++++++++---------------------
 1 file changed, 29 insertions(+), 25 deletions(-)
  

Comments

Jelle Licht July 22, 2016, 2:01 p.m. UTC | #1
Hello guix,

Shamelessly stole most of this from Efraim, as wxwidgets had the same
problem.

Lets hope that it's just a couple of packages on SourceForge that have been
changed in place.


Jelle

2016-07-22 15:59 GMT+02:00 Jelle Licht <jlicht@fsfe.org>:

> * gnu/packages/wxwidgets.scm (wxwidgets-2): Add a guix revision number
>   to the version scheme of wxwidgets-2 to force an update.
> ---
>  gnu/packages/wxwidgets.scm | 54
> +++++++++++++++++++++++++---------------------
>  1 file changed, 29 insertions(+), 25 deletions(-)
>
> diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
> index c9eb178..f4866e1 100644
> --- a/gnu/packages/wxwidgets.scm
> +++ b/gnu/packages/wxwidgets.scm
> @@ -81,29 +81,33 @@ a graphical user interface.  It has language bindings
> for Python, Perl, Ruby
>  and many other languages.")
>      (license (list l:lgpl2.0+ (l:fsf-free "file://doc/license.txt")))))
>
> +;; wxwidgets version 2.8.12 was updated in-place, resulting in a hash
> +;; mismatch. This can be removed at the next version update.
>  (define-public wxwidgets-2
> -  (package
> -    (inherit wxwidgets)
> -    (version "2.8.12")
> -    (source
> -     (origin
> -       (method url-fetch)
> -       (uri (string-append "mirror://sourceforge/wxwindows/" version
> -                           "/wxWidgets-" version ".tar.bz2"))
> -       (sha256
> -        (base32 "1gjs9vfga60mk4j4ngiwsk9h6c7j22pw26m3asxr1jwvqbr8kkqk"))))
> -    (inputs
> -     `(("gtk" ,gtk+-2)
> -       ("libjpeg" ,libjpeg)
> -       ("libtiff" ,libtiff)
> -       ("libmspack" ,libmspack)
> -       ("sdl" ,sdl)
> -       ("unixodbc" ,unixodbc)))
> -    (arguments
> -     `(#:configure-flags
> -       '("--enable-unicode" "--with-regex=sys" "--with-sdl")
> -       #:make-flags
> -       (list (string-append "LDFLAGS=-Wl,-rpath="
> -                            (assoc-ref %outputs "out") "/lib"))
> -       ;; No 'check' target.
> -       #:tests? #f))))
> +  (let ((upstream-version "2.8.12")
> +        (guix-revision "1"))
> +    (package
> +      (inherit wxwidgets)
> +      (version (string-append upstream-version "-" guix-revision))
> +      (source
> +       (origin
> +         (method url-fetch)
> +         (uri (string-append "mirror://sourceforge/wxwindows/"
> upstream-version
> +                             "/wxWidgets-" upstream-version ".tar.bz2"))
> +         (sha256
> +          (base32
> "01zp0h2rp031xn6nd8c4sr175fa4nzhwh08mhi8khs0ps39c22iv"))))
> +      (inputs
> +       `(("gtk" ,gtk+-2)
> +         ("libjpeg" ,libjpeg)
> +         ("libtiff" ,libtiff)
> +         ("libmspack" ,libmspack)
> +         ("sdl" ,sdl)
> +         ("unixodbc" ,unixodbc)))
> +      (arguments
> +       `(#:configure-flags
> +         '("--enable-unicode" "--with-regex=sys" "--with-sdl")
> +         #:make-flags
> +         (list (string-append "LDFLAGS=-Wl,-rpath="
> +                              (assoc-ref %outputs "out") "/lib"))
> +         ;; No 'check' target.
> +         #:tests? #f)))))
> --
> 2.9.1
>
>
  
Vincent Legoll July 22, 2016, 2:09 p.m. UTC | #2
On Fri, Jul 22, 2016 at 4:01 PM, Jelle Licht <jlicht@fsfe.org> wrote:
> packages on SourceForge that have been changed in place.

They have a past history of doing "interesting" things to binary
packages they host... I hope that's not a new batch of those...
  
Leo Famulari July 22, 2016, 4:11 p.m. UTC | #3
On Fri, Jul 22, 2016 at 03:59:48PM +0200, Jelle Licht wrote:
> * gnu/packages/wxwidgets.scm (wxwidgets-2): Add a guix revision number
>   to the version scheme of wxwidgets-2 to force an update.
> -       (uri (string-append "mirror://sourceforge/wxwindows/" version
> -                           "/wxWidgets-" version ".tar.bz2"))
> -       (sha256
> -        (base32 "1gjs9vfga60mk4j4ngiwsk9h6c7j22pw26m3asxr1jwvqbr8kkqk"))))

> +         (uri (string-append "mirror://sourceforge/wxwindows/" upstream-version
> +                             "/wxWidgets-" upstream-version ".tar.bz2"))
> +         (sha256
> +          (base32 "01zp0h2rp031xn6nd8c4sr175fa4nzhwh08mhi8khs0ps39c22iv"))))

Without noticing, I changed the wxwidgets-2.8 URL from the following while
"fixing" changed SourceForge URLs recently:

mirror://sourceforge/wxwindows/wxGTK-" version ".tar.gz

Notice that the tarball name changed from 'wxGTK' to 'wxWidgets'.

So, upstream did not change the package in place. We started fetching
something else accidentally.

Which URL is correct?
  
Andreas Enge July 24, 2016, 8:28 a.m. UTC | #4
Hello,

On Fri, Jul 22, 2016 at 12:11:35PM -0400, Leo Famulari wrote:
> > +         (uri (string-append "mirror://sourceforge/wxwindows/" upstream-version
> > +                             "/wxWidgets-" upstream-version ".tar.bz2"))
> Without noticing, I changed the wxwidgets-2.8 URL from the following while
> "fixing" changed SourceForge URLs recently:
> mirror://sourceforge/wxwindows/wxGTK-" version ".tar.gz
> Notice that the tarball name changed from 'wxGTK' to 'wxWidgets'.
> So, upstream did not change the package in place. We started fetching
> something else accidentally.
> Which URL is correct?

I went to what looks like the official web page:
   https://www.wxwidgets.org/

The given link to the download of the latest release is
   https://github.com/wxWidgets/wxWidgets/releases/download/v3.1.0/wxWidgets-3.1.0.tar.bz2

For the 2.8 series, they give this:
   https://github.com/wxWidgets/wxWidgets/releases/download/v2.8.12/wxGTK-2.8.12.tar.gz
Its hash is the same as what we have in the source.

So I will update the URLs.

Andreas
  

Patch

diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index c9eb178..f4866e1 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -81,29 +81,33 @@  a graphical user interface.  It has language bindings for Python, Perl, Ruby
 and many other languages.")
     (license (list l:lgpl2.0+ (l:fsf-free "file://doc/license.txt")))))
 
+;; wxwidgets version 2.8.12 was updated in-place, resulting in a hash
+;; mismatch. This can be removed at the next version update.
 (define-public wxwidgets-2
-  (package
-    (inherit wxwidgets)
-    (version "2.8.12")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "mirror://sourceforge/wxwindows/" version
-                           "/wxWidgets-" version ".tar.bz2"))
-       (sha256
-        (base32 "1gjs9vfga60mk4j4ngiwsk9h6c7j22pw26m3asxr1jwvqbr8kkqk"))))
-    (inputs
-     `(("gtk" ,gtk+-2)
-       ("libjpeg" ,libjpeg)
-       ("libtiff" ,libtiff)
-       ("libmspack" ,libmspack)
-       ("sdl" ,sdl)
-       ("unixodbc" ,unixodbc)))
-    (arguments
-     `(#:configure-flags
-       '("--enable-unicode" "--with-regex=sys" "--with-sdl")
-       #:make-flags
-       (list (string-append "LDFLAGS=-Wl,-rpath="
-                            (assoc-ref %outputs "out") "/lib"))
-       ;; No 'check' target.
-       #:tests? #f))))
+  (let ((upstream-version "2.8.12")
+        (guix-revision "1"))
+    (package
+      (inherit wxwidgets)
+      (version (string-append upstream-version "-" guix-revision))
+      (source
+       (origin
+         (method url-fetch)
+         (uri (string-append "mirror://sourceforge/wxwindows/" upstream-version
+                             "/wxWidgets-" upstream-version ".tar.bz2"))
+         (sha256
+          (base32 "01zp0h2rp031xn6nd8c4sr175fa4nzhwh08mhi8khs0ps39c22iv"))))
+      (inputs
+       `(("gtk" ,gtk+-2)
+         ("libjpeg" ,libjpeg)
+         ("libtiff" ,libtiff)
+         ("libmspack" ,libmspack)
+         ("sdl" ,sdl)
+         ("unixodbc" ,unixodbc)))
+      (arguments
+       `(#:configure-flags
+         '("--enable-unicode" "--with-regex=sys" "--with-sdl")
+         #:make-flags
+         (list (string-append "LDFLAGS=-Wl,-rpath="
+                              (assoc-ref %outputs "out") "/lib"))
+         ;; No 'check' target.
+         #:tests? #f)))))