[2/2] gnu: Add allegro-5.0.
Commit Message
* gnu/packages/game-development.scm (allegro-5.0): New variable.
---
gnu/packages/game-development.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)
Comments
On Tue, Jul 19, 2016 at 4:57 PM, Ricardo Wurmus <rekado@elephly.net> wrote:
> * gnu/packages/game-development.scm (allegro-5.0): New variable.
I assume you have a use-case that calls for keeping multiple versions
of Allegro 5 around? Looks fine to me, if so.
- Dave
Thompson, David <dthompson2@worcester.edu> writes:
> On Tue, Jul 19, 2016 at 4:57 PM, Ricardo Wurmus <rekado@elephly.net> wrote:
>> * gnu/packages/game-development.scm (allegro-5.0): New variable.
>
> I assume you have a use-case that calls for keeping multiple versions
> of Allegro 5 around? Looks fine to me, if so.
Allegro 5.2 merges the unstable with the stable branch. It breaks API
and requires applications to define “ALLEGRO_UNSTABLE” to use unstable
features.
Allegro 5.0.11 is the last of the stable releases and the last to use
the pkg-config identifier “allegro-5.0”, which some applications look
for.
I’m not sure if this is enough to justify keeping 5.0 or if we should
patch the configure scripts of applications that look for “allegro-5.0”.
~~ Ricardo
On Wed, Jul 20, 2016 at 1:52 AM, Ricardo Wurmus <rekado@elephly.net> wrote:
>
> Thompson, David <dthompson2@worcester.edu> writes:
>
>> On Tue, Jul 19, 2016 at 4:57 PM, Ricardo Wurmus <rekado@elephly.net> wrote:
>>> * gnu/packages/game-development.scm (allegro-5.0): New variable.
>>
>> I assume you have a use-case that calls for keeping multiple versions
>> of Allegro 5 around? Looks fine to me, if so.
>
> Allegro 5.2 merges the unstable with the stable branch. It breaks API
> and requires applications to define “ALLEGRO_UNSTABLE” to use unstable
> features.
>
> Allegro 5.0.11 is the last of the stable releases and the last to use
> the pkg-config identifier “allegro-5.0”, which some applications look
> for.
>
> I’m not sure if this is enough to justify keeping 5.0 or if we should
> patch the configure scripts of applications that look for “allegro-5.0”.
I think this is a good reason to keep a 5.0 package around. Thanks
for explaining.
- Dave
@@ -383,6 +383,18 @@ etc.")
(home-page "http://liballeg.org")
(license license:bsd-3)))
+(define-public allegro-5.0
+ (package (inherit allegro)
+ (name "allegro")
+ (version "5.0.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://download.gna.org/allegro/allegro/"
+ version "/allegro-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0cd51qrh97jrr0xdmnivqgwljpmizg8pixsgvc4blqqlaz4i9zj9"))))))
+
(define-public aseprite
(package
(name "aseprite")