[1/2] gnu: geda-gaf: Use modify-phases syntax.
Commit Message
* gnu/packages/engineering.scm (geda-gaf)[arguments]: Use modify-phases
syntax.
---
gnu/packages/engineering.scm | 13 ++++++-------
1 file changed, 6 insertions(+), 7 deletions(-)
Comments
Ricardo Wurmus <rekado@elephly.net> skribis:
> * gnu/packages/engineering.scm (geda-gaf)[arguments]: Use modify-phases
> syntax.
OK!
@@ -123,13 +123,12 @@ plans and designs.")
(build-system gnu-build-system)
(arguments
'(#:phases
- ;; tests require a writable HOME
- (alist-cons-before
- 'check 'set-home
- (lambda _
- (setenv "HOME" (getenv "TMPDIR")))
- %standard-phases
- )
+ (modify-phases %standard-phases
+ ;; tests require a writable HOME
+ (add-before 'check 'set-home
+ (lambda _
+ (setenv "HOME" (getenv "TMPDIR"))
+ #t)))
#:configure-flags
(let ((pcb (assoc-ref %build-inputs "pcb")))
(list (string-append "--with-pcb-datadir=" pcb "/share")