[1/2] gnu: geda-gaf: Use modify-phases syntax.

Message ID 20160713193228.23647-2-rekado@elephly.net
State New
Headers

Commit Message

Ricardo Wurmus July 13, 2016, 7:32 p.m. UTC
  * gnu/packages/engineering.scm (geda-gaf)[arguments]: Use modify-phases
  syntax.
---
 gnu/packages/engineering.scm | 13 ++++++-------
 1 file changed, 6 insertions(+), 7 deletions(-)
  

Comments

Ludovic Courtès July 16, 2016, 1:14 p.m. UTC | #1
Ricardo Wurmus <rekado@elephly.net> skribis:

> * gnu/packages/engineering.scm (geda-gaf)[arguments]: Use modify-phases
>   syntax.

OK!
  

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 3822331..d7bd06f 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -123,13 +123,12 @@  plans and designs.")
     (build-system gnu-build-system)
     (arguments
      '(#:phases
-       ;; tests require a writable HOME
-       (alist-cons-before
-        'check 'set-home
-        (lambda _
-          (setenv "HOME" (getenv "TMPDIR")))
-        %standard-phases
-        )
+       (modify-phases %standard-phases
+         ;; tests require a writable HOME
+         (add-before 'check 'set-home
+           (lambda _
+             (setenv "HOME" (getenv "TMPDIR"))
+             #t)))
        #:configure-flags
        (let ((pcb (assoc-ref %build-inputs "pcb")))
          (list (string-append "--with-pcb-datadir=" pcb "/share")