[03/17] gnu: Add emacs-expand-region.

Message ID 20160712210514.21310-4-rekado@elephly.net
State New
Headers

Commit Message

Ricardo Wurmus July 12, 2016, 9:05 p.m. UTC
  * gnu/packages/emacs.scm (emacs-expand-region): New variable.
---
 gnu/packages/emacs.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
  

Comments

Alex Kost July 15, 2016, 2:25 p.m. UTC | #1
Ricardo Wurmus (2016-07-13 00:05 +0300) wrote:

> * gnu/packages/emacs.scm (emacs-expand-region): New variable.
> ---
>  gnu/packages/emacs.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
>
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index cd87c79..169df4c 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -1330,6 +1330,30 @@ Expectations, but it can be used in other contexts.")
>  definitions for testing with the Ecukes framework.")
>      (license license:gpl3+)))
>  
> +(define-public emacs-expand-region
> +  (package
> +    (name "emacs-expand-region")
> +    (version "0.10.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://github.com/magnars/expand-region.el"
> +                           "/archive/" version ".tar.gz"))
> +       (file-name (string-append name "-" version ".tar.gz"))
> +       (sha256
> +        (base32
> +         "1zfiaqyb3zqiyqjkpqsjw660j09805nqsg25q6ars2h8gs0rnvxb"))))
> +    (build-system emacs-build-system)
> +    (native-inputs
> +     `(("emacs-espuds" ,emacs-espuds)))

Is it really needed?  AFAIU this is needed only for some development
things in "feature" subdir (Cask maybe, dunno).  If you add it to
compile "features/support/env.el", then it wasn't compiled anyway.

My understanding for emacs packages is that we try to prepare a user
package (what (M)ELPA does), and we don't care about various additional
cask, maintainer, development stuff.  WDYT?

> +    (home-page "https://github.com/magnars/expand-region.el")
> +    (synopsis "Increase selected region by semantic units")
> +    (description
> +     "Expand region increases the selected region by semantic units.  Just
> +keep pressing the key until it selects what you want.  There's also
> +@code{er/contract-region} if you expand too far.")
> +    (license license:gpl3+)))
> +
>  (define-public emacs-ob-ipython
>    (package
>      (name "emacs-ob-ipython")
  

Patch

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index cd87c79..169df4c 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1330,6 +1330,30 @@  Expectations, but it can be used in other contexts.")
 definitions for testing with the Ecukes framework.")
     (license license:gpl3+)))
 
+(define-public emacs-expand-region
+  (package
+    (name "emacs-expand-region")
+    (version "0.10.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/magnars/expand-region.el"
+                           "/archive/" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1zfiaqyb3zqiyqjkpqsjw660j09805nqsg25q6ars2h8gs0rnvxb"))))
+    (build-system emacs-build-system)
+    (native-inputs
+     `(("emacs-espuds" ,emacs-espuds)))
+    (home-page "https://github.com/magnars/expand-region.el")
+    (synopsis "Increase selected region by semantic units")
+    (description
+     "Expand region increases the selected region by semantic units.  Just
+keep pressing the key until it selects what you want.  There's also
+@code{er/contract-region} if you expand too far.")
+    (license license:gpl3+)))
+
 (define-public emacs-ob-ipython
   (package
     (name "emacs-ob-ipython")