[02/17] gnu: Add emacs-espuds.

Message ID 20160712210514.21310-3-rekado@elephly.net
State New
Headers

Commit Message

Ricardo Wurmus July 12, 2016, 9:04 p.m. UTC
  * gnu/packages/emacs.scm (emacs-espuds): New variable.
---
 gnu/packages/emacs.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
  

Comments

Alex Kost July 15, 2016, 2:14 p.m. UTC | #1
Ricardo Wurmus (2016-07-13 00:04 +0300) wrote:

> * gnu/packages/emacs.scm (emacs-espuds): New variable.
> ---
>  gnu/packages/emacs.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)
>
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 95c8d9b..cd87c79 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -1305,6 +1305,31 @@ syntax.  Most commonly Emacs Lisp Mock is used in conjunction with Emacs Lisp
>  Expectations, but it can be used in other contexts.")
>      (license license:gpl3+)))
>  
> +(define-public emacs-espuds
> +  (package
> +    (name "emacs-espuds")
> +    (version "0.3.3")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://github.com/ecukes/espuds/"
> +                           "archive/v" version ".tar.gz"))
> +       (file-name (string-append name "-" version ".tar.gz"))
> +       (sha256
> +        (base32
> +         "0xv551376pbmh735a3zjwc9z4qdx6ngj1vpq3xqjpn0a1rwjyn4k"))))
> +    (build-system emacs-build-system)
> +    (propagated-inputs
> +     `(("emacs-el-mock" ,emacs-el-mock)

This is needed only for files from "test" subdir but the tests are not
run anyway.  I would just remove it.  Even if the tests will be checked
during the build process, "emacs-el-mock" shouldn't be propagated as it
is not a dependency of the "espuds.el".  Or do I miss anything?

> +       ("emacs-s" ,emacs-s)
> +       ("emacs-dash" ,emacs-dash)
> +       ("emacs-f" ,emacs-f)))
> +    (home-page "http://github.com/ecukes/espuds")
> +    (synopsis "Common step definitions for Ecukes")
> +    (description "Espuds is a collection of the most commonly used step
> +definitions for testing with the Ecukes framework.")
> +    (license license:gpl3+)))
> +
>  (define-public emacs-ob-ipython
>    (package
>      (name "emacs-ob-ipython")
  

Patch

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 95c8d9b..cd87c79 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1305,6 +1305,31 @@  syntax.  Most commonly Emacs Lisp Mock is used in conjunction with Emacs Lisp
 Expectations, but it can be used in other contexts.")
     (license license:gpl3+)))
 
+(define-public emacs-espuds
+  (package
+    (name "emacs-espuds")
+    (version "0.3.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/ecukes/espuds/"
+                           "archive/v" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0xv551376pbmh735a3zjwc9z4qdx6ngj1vpq3xqjpn0a1rwjyn4k"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-el-mock" ,emacs-el-mock)
+       ("emacs-s" ,emacs-s)
+       ("emacs-dash" ,emacs-dash)
+       ("emacs-f" ,emacs-f)))
+    (home-page "http://github.com/ecukes/espuds")
+    (synopsis "Common step definitions for Ecukes")
+    (description "Espuds is a collection of the most commonly used step
+definitions for testing with the Ecukes framework.")
+    (license license:gpl3+)))
+
 (define-public emacs-ob-ipython
   (package
     (name "emacs-ob-ipython")