[15/17] gnu: Add emacs-tagedit.
Commit Message
* gnu/packages/emacs.scm (emacs-tagedit): New variable.
---
gnu/packages/emacs.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
Comments
Ricardo Wurmus (2016-07-13 00:05 +0300) wrote:
> * gnu/packages/emacs.scm (emacs-tagedit): New variable.
> ---
> gnu/packages/emacs.scm | 26 ++++++++++++++++++++++++++
> 1 file changed, 26 insertions(+)
>
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 64192cc..283ed56 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -1862,6 +1862,32 @@ identifiers in the MIT-Scheme documentation.")
> constants and units into an Emacs buffer.")
> (license license:gpl2+)))
>
> +(define-public emacs-tagedit
> + (package
> + (name "emacs-tagedit")
> + (version "1.4.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/magnars/tagedit/"
> + "archive/" version ".tar.gz"))
> + (file-name (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "1apfnann4qklfdsmdi7icjsj18x7gwx8d83iqr4z25clszz95xfq"))))
> + (build-system emacs-build-system)
> + (native-inputs
> + `(("emacs-espuds" ,emacs-espuds)))
The same comment: I think it is not needed. Or do you think it should
be added? Why?
> + (propagated-inputs
> + `(("emacs-s" ,emacs-s)
> + ("emacs-dash" ,emacs-dash)))
> + (home-page "https://github.com/magnars/tagedit")
> + (synopsis "Some paredit-like features for html-mode")
> + (description
> + "This package provides a collection of paredit-like functions for editing
> +in @code{html-mode}.")
> + (license license:gpl3+)))
> +
> (define-public emacs-slime
> (package
> (name "emacs-slime")
@@ -1862,6 +1862,32 @@ identifiers in the MIT-Scheme documentation.")
constants and units into an Emacs buffer.")
(license license:gpl2+)))
+(define-public emacs-tagedit
+ (package
+ (name "emacs-tagedit")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/magnars/tagedit/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1apfnann4qklfdsmdi7icjsj18x7gwx8d83iqr4z25clszz95xfq"))))
+ (build-system emacs-build-system)
+ (native-inputs
+ `(("emacs-espuds" ,emacs-espuds)))
+ (propagated-inputs
+ `(("emacs-s" ,emacs-s)
+ ("emacs-dash" ,emacs-dash)))
+ (home-page "https://github.com/magnars/tagedit")
+ (synopsis "Some paredit-like features for html-mode")
+ (description
+ "This package provides a collection of paredit-like functions for editing
+in @code{html-mode}.")
+ (license license:gpl3+)))
+
(define-public emacs-slime
(package
(name "emacs-slime")