[14/17] gnu: Add emacs-shell-switcher.
Commit Message
* gnu/packages/emacs.scm (emacs-shell-switcher): New variable.
---
gnu/packages/emacs.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
Comments
Ricardo Wurmus (2016-07-13 00:05 +0300) wrote:
> * gnu/packages/emacs.scm (emacs-shell-switcher): New variable.
> ---
> gnu/packages/emacs.scm | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)
>
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index f544721..64192cc 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -1581,6 +1581,30 @@ read from small to large monitors by using colors, a prefix feature, and smart
> truncation.")
> (license license:gpl2+)))
>
> +(define-public emacs-shell-switcher
> + (package
> + (name "emacs-shell-switcher")
> + (version "1.0.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/DamienCassou/shell-switcher"
> + "/archive/v" version ".tar.gz"))
> + (file-name (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "1c23mfkdqz2g9rixd9smm323vzlvhzz3ng34ambcqjfq309qb2nz"))))
> + (build-system emacs-build-system)
> + (native-inputs
> + `(("emacs-espuds" ,emacs-espuds)
> + ("emacs-undercover" ,emacs-undercover)
> + ("emacs-f" ,emacs-f)))
The same comment: all three are not needed IMO, they do nothing useful.
> + (home-page "https://github.com/DamienCassou/shell-switcher")
> + (synopsis "Provide fast switching between shell buffers")
> + (description
> + "This package provides commands to quickly switch between shell buffers.")
> + (license license:gpl3+)))
> +
> (define-public emacs-ob-ipython
> (package
> (name "emacs-ob-ipython")
@@ -1581,6 +1581,30 @@ read from small to large monitors by using colors, a prefix feature, and smart
truncation.")
(license license:gpl2+)))
+(define-public emacs-shell-switcher
+ (package
+ (name "emacs-shell-switcher")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/DamienCassou/shell-switcher"
+ "/archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1c23mfkdqz2g9rixd9smm323vzlvhzz3ng34ambcqjfq309qb2nz"))))
+ (build-system emacs-build-system)
+ (native-inputs
+ `(("emacs-espuds" ,emacs-espuds)
+ ("emacs-undercover" ,emacs-undercover)
+ ("emacs-f" ,emacs-f)))
+ (home-page "https://github.com/DamienCassou/shell-switcher")
+ (synopsis "Provide fast switching between shell buffers")
+ (description
+ "This package provides commands to quickly switch between shell buffers.")
+ (license license:gpl3+)))
+
(define-public emacs-ob-ipython
(package
(name "emacs-ob-ipython")