[12/17] gnu: Add emacs-shut-up.
Commit Message
* gnu/packages/emacs.scm (emacs-shut-up): New variable.
---
gnu/packages/emacs.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
Comments
Ricardo Wurmus (2016-07-13 00:05 +0300) wrote:
> * gnu/packages/emacs.scm (emacs-shut-up): New variable.
> ---
> gnu/packages/emacs.scm | 23 +++++++++++++++++++++++
> 1 file changed, 23 insertions(+)
>
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 2dd886f..ed3a1e3 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -1395,6 +1395,29 @@ column by drawing a thin line down the length of the editing window.")
> IRC bouncer with ERC.")
> (license license:expat)))
>
> +(define-public emacs-shut-up
> + (package
> + (name "emacs-shut-up")
> + (version "0.3.2")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/cask/shut-up/"
> + "archive/v" version ".tar.gz"))
> + (file-name (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "09kzrjdkb569iviyg7ydwq44yh84m3f9hkl7jizfrlk0w4gz67d1"))))
> + (build-system emacs-build-system)
> + (propagated-inputs
> + `(("emacs-f" ,emacs-f)
> + ("emacs-s" ,emacs-s)))
"f" and "s" are only for "test" subdir and they have no effect on the
package itself ("shut-up.el" file). The only benefit is that
"test/test-helper.el" file is compiled, but it doesn't give anything to
the end user. So I would remove them (at least they shouldn't be
propagated).
> + (home-page "https://github.com/cask/shut-up")
> + (synopsis "Silence Emacs")
> + (description "This package silences most output of Emacs when running an
> +Emacs shell script.")
> + (license license:expat)))
> +
> (define-public emacs-paren-face
> (package
> (name "emacs-paren-face")
@@ -1395,6 +1395,29 @@ column by drawing a thin line down the length of the editing window.")
IRC bouncer with ERC.")
(license license:expat)))
+(define-public emacs-shut-up
+ (package
+ (name "emacs-shut-up")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/cask/shut-up/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "09kzrjdkb569iviyg7ydwq44yh84m3f9hkl7jizfrlk0w4gz67d1"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-f" ,emacs-f)
+ ("emacs-s" ,emacs-s)))
+ (home-page "https://github.com/cask/shut-up")
+ (synopsis "Silence Emacs")
+ (description "This package silences most output of Emacs when running an
+Emacs shell script.")
+ (license license:expat)))
+
(define-public emacs-paren-face
(package
(name "emacs-paren-face")