[05/10] gnu: Add python-cleo and python2-cleo.
Commit Message
* gnu/packages/python.scm (python-cleo, python2-cleo): New variables.
---
gnu/packages/python.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
Comments
On Thu, Jun 23, 2016 at 11:19:59PM +0800, 宋文武 wrote:
> * gnu/packages/python.scm (python-cleo, python2-cleo): New variables.
> ---
> gnu/packages/python.scm | 28 ++++++++++++++++++++++++++++
> 1 file changed, 28 insertions(+)
>
> diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> index 1dc5212..d1d127b 100644
> --- a/gnu/packages/python.scm
> +++ b/gnu/packages/python.scm
> @@ -9391,3 +9391,31 @@ Wikipedia code samples at
> (define-public python2-pylev
> (package-with-python2 python-pylev))
>
> +(define-public python-cleo
> + (package
> + (name "python-cleo")
> + (version "0.4.1")
> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "cleo" version))
> + (sha256
> + (base32
> + "1k2dcl6mqpn5bljyl6w42rqyd9mb3y9kh2mg7m2x3kfjwvg0rpva"))))
> + (build-system python-build-system)
> + (native-inputs
> + `(("python-psutil" ,python-psutil)
> + ("python-pylev" ,python-pylev)
> + ("python-setuptools" ,python-setuptools)
> + ;; For testing
> + ("python-mock" ,python-mock)
> + ("python-pytest" ,python-pytest)))
> + (home-page "https://github.com/sdispater/cleo")
> + (synopsis "Command-line arguments library for Python")
> + (description
> + "Cleo allows you to create command-line commands with signature in
> +docstring and colored output.")
How about "command-line interfaces"? Also, I don't know what "signature
in docstring" means? Is that something that Python programmers (not me)
would understand?
> + (license license:expat)))
> +
> +(define-public python2-cleo
> + (package-with-python2 python-cleo))
> +
> --
> 2.8.4
>
>
@@ -9391,3 +9391,31 @@ Wikipedia code samples at
(define-public python2-pylev
(package-with-python2 python-pylev))
+(define-public python-cleo
+ (package
+ (name "python-cleo")
+ (version "0.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "cleo" version))
+ (sha256
+ (base32
+ "1k2dcl6mqpn5bljyl6w42rqyd9mb3y9kh2mg7m2x3kfjwvg0rpva"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-psutil" ,python-psutil)
+ ("python-pylev" ,python-pylev)
+ ("python-setuptools" ,python-setuptools)
+ ;; For testing
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/sdispater/cleo")
+ (synopsis "Command-line arguments library for Python")
+ (description
+ "Cleo allows you to create command-line commands with signature in
+docstring and colored output.")
+ (license license:expat)))
+
+(define-public python2-cleo
+ (package-with-python2 python-cleo))
+