[03/10] gnu: Add python-inflection and python2-inflection.
Commit Message
* gnu/packages/python.scm (python-inflection, python2-inflection):
New variables.
---
gnu/packages/python.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
Comments
On Thu, Jun 23, 2016 at 11:18:50PM +0800, 宋文武 wrote:
> * gnu/packages/python.scm (python-inflection, python2-inflection):
> New variables.
> ---
> gnu/packages/python.scm | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> index 6e30377..ced8232 100644
> --- a/gnu/packages/python.scm
> +++ b/gnu/packages/python.scm
> @@ -9344,3 +9344,27 @@ datetime type.")
> (define-public python2-arrow
> (package-with-python2 python-arrow))
>
> +(define-public python-inflection
> + (package
> + (name "python-inflection")
> + (version "0.3.1")
> + (source
> + (origin (method url-fetch)
> + (uri (pypi-uri "inflection" version))
> + (sha256
> + (base32
> + "1jhnxgnw8y3mbzjssixh6qkc7a3afc4fygajhqrqalnilyvpzshq"))))
The indentation should be shifted to the right.
> + (build-system python-build-system)
> + (native-inputs
> + `(("python-setuptools" ,python-setuptools)))
> + (home-page "http://github.com/jpvanhal/inflection")
> + (synopsis "Python string transformation library")
> + (description
> + "Inflection is a string transformation library. It singularizes
> +and pluralizes English words, and transforms strings from CamelCase to
> +underscored string.")
> + (license license:expat)))
> +
> +(define-public python2-inflection
> + (package-with-python2 python-inflection))
> +
> --
> 2.8.4
>
>
@@ -9344,3 +9344,27 @@ datetime type.")
(define-public python2-arrow
(package-with-python2 python-arrow))
+(define-public python-inflection
+ (package
+ (name "python-inflection")
+ (version "0.3.1")
+ (source
+ (origin (method url-fetch)
+ (uri (pypi-uri "inflection" version))
+ (sha256
+ (base32
+ "1jhnxgnw8y3mbzjssixh6qkc7a3afc4fygajhqrqalnilyvpzshq"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://github.com/jpvanhal/inflection")
+ (synopsis "Python string transformation library")
+ (description
+ "Inflection is a string transformation library. It singularizes
+and pluralizes English words, and transforms strings from CamelCase to
+underscored string.")
+ (license license:expat)))
+
+(define-public python2-inflection
+ (package-with-python2 python-inflection))
+