[5/6] gnu: Add emacs-iedit.
Commit Message
* gnu/packages/emacs.scm (emacs-iedit): New variable.
---
gnu/packages/emacs.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
Comments
Ricardo Wurmus (2016-06-18 19:15 +0300) wrote:
> * gnu/packages/emacs.scm (emacs-iedit): New variable.
> ---
> gnu/packages/emacs.scm | 26 ++++++++++++++++++++++++++
> 1 file changed, 26 insertions(+)
LGTM, thanks!
@@ -1829,6 +1829,32 @@ called. If there are more, each window will have its first character
highlighted. Pressing that character will switch to that window.")
(license license:gpl3+)))
+(define-public emacs-iedit
+ (package
+ (name "emacs-iedit")
+ (version "0.9.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/victorhge/iedit/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "00v86zllcsivmiibigbr91qij2zdf1lr9db8z8again1sn63wkdj"))))
+ (build-system emacs-build-system)
+ (home-page "http://www.emacswiki.org/emacs/Iedit")
+ (synopsis "Edit multiple regions in the same way simultaneously")
+ (description
+ "This package is an Emacs minor mode and allows you to edit one
+occurrence of some text in a buffer (possibly narrowed) or region, and
+simultaneously have other occurrences edited in the same way.
+
+You can also use Iedit mode as a quick way to temporarily show only the buffer
+lines that match the current text being edited. This gives you the effect of
+a temporary @code{keep-lines} or @code{occur}.")
+ (license license:gpl3+)))
+
(define-public emacs-clojure-mode
(package
(name "emacs-clojure-mode")