[4/6] gnu: Add emacs-ace-window.
Commit Message
* gnu/packages/emacs.scm (emacs-ace-window): New variable.
---
gnu/packages/emacs.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
Comments
Ricardo Wurmus (2016-06-18 19:15 +0300) wrote:
> * gnu/packages/emacs.scm (emacs-ace-window): New variable.
> ---
> gnu/packages/emacs.scm | 25 +++++++++++++++++++++++++
> 1 file changed, 25 insertions(+)
>
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 5158059..7104165 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -1804,6 +1804,31 @@ such as
> @end enumerate\n")
> (license license:gpl3+)))
>
> +(define-public emacs-ace-window
> + (package
> + (name "emacs-ace-window")
> + (version "0.9.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/abo-abo/ace-window/archive/"
> + version ".tar.gz"))
> + (file-name (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "1p2sgfl5dml4zbd6ldql6lm2m9vmd236ah996ni32x254s48j5pn"))))
> + (build-system emacs-build-system)
> + (propagated-inputs
> + `(("emacs-avy" ,emacs-avy)))
> + (home-page "https://github.com/abo-abo/ace-window")
> + (synopsis "Quickly switch windows")
I don't have comments on this package except for the same question about
mentioning "Emacs". Maybe: "Quickly switch windows in Emacs"?
> + (description
> + "@code{ace-window} is meant to replace @code{other-window}.
> +In fact, when there are only two windows present, @code{other-window} is
> +called. If there are more, each window will have its first character
> +highlighted. Pressing that character will switch to that window.")
> + (license license:gpl3+)))
> +
> (define-public emacs-clojure-mode
> (package
> (name "emacs-clojure-mode")
@@ -1804,6 +1804,31 @@ such as
@end enumerate\n")
(license license:gpl3+)))
+(define-public emacs-ace-window
+ (package
+ (name "emacs-ace-window")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/abo-abo/ace-window/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1p2sgfl5dml4zbd6ldql6lm2m9vmd236ah996ni32x254s48j5pn"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-avy" ,emacs-avy)))
+ (home-page "https://github.com/abo-abo/ace-window")
+ (synopsis "Quickly switch windows")
+ (description
+ "@code{ace-window} is meant to replace @code{other-window}.
+In fact, when there are only two windows present, @code{other-window} is
+called. If there are more, each window will have its first character
+highlighted. Pressing that character will switch to that window.")
+ (license license:gpl3+)))
+
(define-public emacs-clojure-mode
(package
(name "emacs-clojure-mode")