[3/6] gnu: Add emacs-avy.
Commit Message
* gnu/packages/emacs.scm (emacs-avy): New variable.
---
gnu/packages/emacs.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
Comments
Ricardo Wurmus (2016-06-18 19:15 +0300) wrote:
> * gnu/packages/emacs.scm (emacs-avy): New variable.
> ---
> gnu/packages/emacs.scm | 36 ++++++++++++++++++++++++++++++++++++
> 1 file changed, 36 insertions(+)
>
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 6741f58..5158059 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -1768,6 +1768,42 @@ his orignal purpose, calling his proper command. This makes the Hydra very
> seamless, it's like a minor mode that disables itself automatically.")
> (license license:gpl3+)))
>
> +(define-public emacs-avy
> + (package
> + (name "emacs-avy")
> + (version "0.4.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/abo-abo/avy/archive/"
> + version ".tar.gz"))
> + (file-name (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "1wdrq512h25ymzjbf2kbsdymvd2ryfwzb6bh5bc3yv7q203im796"))))
> + (build-system emacs-build-system)
> + (home-page "https://github.com/abo-abo/avy")
> + (synopsis "Tree-based completion")
I would write "Tree-based completion for Emacs", but I'm not sure if we
have a convention to mention "Emacs" in synopsis or description of emacs
packages.
> + (description
> + "This package provides a generic completion method based on building a
> +balanced decision tree with each candidate being a leaf. To traverse the tree
> +from the root to a desired leaf, typically a sequence of @code{read-key} can
> +be used.
> +
> +In order for @code{read-key} to make sense, the tree needs to be visualized
> +appropriately, with a character at each branch node. So this completion
> +method works only for things that you can see on your screen, all at once,
> +such as
> +
> +@enumerate
> +@item character positions
> +@item word or subword start positions
> +@item line beginning positions
> +@item link positions
> +@item window positions
> +@end enumerate\n")
I think this description is a bit too long, but I'm fine with it except
the last "\n", I would remove it :-)
> + (license license:gpl3+)))
> +
> (define-public emacs-clojure-mode
> (package
> (name "emacs-clojure-mode")
Alex Kost <alezost@gmail.com> writes:
> Ricardo Wurmus (2016-06-18 19:15 +0300) wrote:
>
>> * gnu/packages/emacs.scm (emacs-avy): New variable.
>> ---
>> gnu/packages/emacs.scm | 36 ++++++++++++++++++++++++++++++++++++
>> 1 file changed, 36 insertions(+)
>>
>>
>> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
>> index 6741f58..5158059 100644
>> --- a/gnu/packages/emacs.scm
>> +++ b/gnu/packages/emacs.scm
>> @@ -1768,6 +1768,42 @@ his orignal purpose, calling his proper command. This makes the Hydra very
>> seamless, it's like a minor mode that disables itself automatically.")
>> (license license:gpl3+)))
>>
>> +(define-public emacs-avy
>> + (package
>> + (name "emacs-avy")
>> + (version "0.4.0")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append "https://github.com/abo-abo/avy/archive/"
>> + version ".tar.gz"))
>> + (file-name (string-append name "-" version ".tar.gz"))
>> + (sha256
>> + (base32
>> + "1wdrq512h25ymzjbf2kbsdymvd2ryfwzb6bh5bc3yv7q203im796"))))
>> + (build-system emacs-build-system)
>> + (home-page "https://github.com/abo-abo/avy")
>> + (synopsis "Tree-based completion")
>
> I would write "Tree-based completion for Emacs", but I'm not sure if we
> have a convention to mention "Emacs" in synopsis or description of emacs
> packages.
Okay.
>> + (description
>> + "This package provides a generic completion method based on building a
>> +balanced decision tree with each candidate being a leaf. To traverse the tree
>> +from the root to a desired leaf, typically a sequence of @code{read-key} can
>> +be used.
>> +
>> +In order for @code{read-key} to make sense, the tree needs to be visualized
>> +appropriately, with a character at each branch node. So this completion
>> +method works only for things that you can see on your screen, all at once,
>> +such as
>> +
>> +@enumerate
>> +@item character positions
>> +@item word or subword start positions
>> +@item line beginning positions
>> +@item link positions
>> +@item window positions
>> +@end enumerate\n")
>
> I think this description is a bit too long, but I'm fine with it except
> the last "\n", I would remove it :-)
I have inlined the enumeration and shortened the items.
~~ Ricardo
@@ -1768,6 +1768,42 @@ his orignal purpose, calling his proper command. This makes the Hydra very
seamless, it's like a minor mode that disables itself automatically.")
(license license:gpl3+)))
+(define-public emacs-avy
+ (package
+ (name "emacs-avy")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/abo-abo/avy/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1wdrq512h25ymzjbf2kbsdymvd2ryfwzb6bh5bc3yv7q203im796"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/abo-abo/avy")
+ (synopsis "Tree-based completion")
+ (description
+ "This package provides a generic completion method based on building a
+balanced decision tree with each candidate being a leaf. To traverse the tree
+from the root to a desired leaf, typically a sequence of @code{read-key} can
+be used.
+
+In order for @code{read-key} to make sense, the tree needs to be visualized
+appropriately, with a character at each branch node. So this completion
+method works only for things that you can see on your screen, all at once,
+such as
+
+@enumerate
+@item character positions
+@item word or subword start positions
+@item line beginning positions
+@item link positions
+@item window positions
+@end enumerate\n")
+ (license license:gpl3+)))
+
(define-public emacs-clojure-mode
(package
(name "emacs-clojure-mode")