[1/6] gnu: Add emacs-ivy.
Commit Message
* gnu/packages/emacs.scm (emacs-ivy): New variable.
---
gnu/packages/emacs.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
Comments
Ricardo Wurmus (2016-06-18 19:15 +0300) wrote:
> * gnu/packages/emacs.scm (emacs-ivy): New variable.
> ---
> gnu/packages/emacs.scm | 25 +++++++++++++++++++++++++
> 1 file changed, 25 insertions(+)
>
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index d524a7c..c12bf12 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -1717,6 +1717,31 @@ features found in other packages it also brings many improvements as
> well as completely new features.")
> (license license:gpl3+)))
>
> +(define-public emacs-ivy
> + (package
> + (name "emacs-ivy")
> + (version "0.8.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/abo-abo/swiper/archive/"
> + version ".tar.gz"))
> + (file-name (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "18nqwl05is71dzswnvpfhlg7b0v3apvbsfxrwab9c0apwavi892q"))))
> + (build-system emacs-build-system)
> + (home-page "https://github.com/abo-abo/swiper")
Since this is more a home of the source code, perhaps it would make
sense to point to "http://oremacs.com/swiper/" as the homepage?
> + (synopsis "Incremental vertical completion")
> + (description
> + "This package provides @code{ivy-read} as an alternative to
> +@code{completing-read} and similar functions. No attempt is made to determine
> +the best candidate. Instead, the user can navigate candidates with
> +@code{ivy-next-line} and @code{ivy-previous-line}. The matching is done by
> +splitting the input text by spaces and re-building it into a regular
> +expression.")
> + (license license:gpl3+)))
This package has "ivy-hydra.el" file and it cannot be compiled as it
requires 'hydra'. Although it's an additional feature only for hydra
users, but maybe it would be good to add 'emacs-hydra' input here, WDYT?
Alex Kost <alezost@gmail.com> writes:
> Ricardo Wurmus (2016-06-18 19:15 +0300) wrote:
>
>> * gnu/packages/emacs.scm (emacs-ivy): New variable.
>> ---
>> gnu/packages/emacs.scm | 25 +++++++++++++++++++++++++
>> 1 file changed, 25 insertions(+)
>>
>>
>> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
>> index d524a7c..c12bf12 100644
>> --- a/gnu/packages/emacs.scm
>> +++ b/gnu/packages/emacs.scm
>> @@ -1717,6 +1717,31 @@ features found in other packages it also brings many improvements as
>> well as completely new features.")
>> (license license:gpl3+)))
>>
>> +(define-public emacs-ivy
>> + (package
>> + (name "emacs-ivy")
>> + (version "0.8.0")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append "https://github.com/abo-abo/swiper/archive/"
>> + version ".tar.gz"))
>> + (file-name (string-append name "-" version ".tar.gz"))
>> + (sha256
>> + (base32
>> + "18nqwl05is71dzswnvpfhlg7b0v3apvbsfxrwab9c0apwavi892q"))))
>> + (build-system emacs-build-system)
>> + (home-page "https://github.com/abo-abo/swiper")
>
> Since this is more a home of the source code, perhaps it would make
> sense to point to "http://oremacs.com/swiper/" as the homepage?
Okay, makes sense.
>
>> + (synopsis "Incremental vertical completion")
>> + (description
>> + "This package provides @code{ivy-read} as an alternative to
>> +@code{completing-read} and similar functions. No attempt is made to determine
>> +the best candidate. Instead, the user can navigate candidates with
>> +@code{ivy-next-line} and @code{ivy-previous-line}. The matching is done by
>> +splitting the input text by spaces and re-building it into a regular
>> +expression.")
>> + (license license:gpl3+)))
>
> This package has "ivy-hydra.el" file and it cannot be compiled as it
> requires 'hydra'. Although it's an additional feature only for hydra
> users, but maybe it would be good to add 'emacs-hydra' input here, WDYT?
Okay, I’ll reorder the patches and add emacs-hydra as a propagated
input.
~~ Ricardo
@@ -1717,6 +1717,31 @@ features found in other packages it also brings many improvements as
well as completely new features.")
(license license:gpl3+)))
+(define-public emacs-ivy
+ (package
+ (name "emacs-ivy")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/abo-abo/swiper/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "18nqwl05is71dzswnvpfhlg7b0v3apvbsfxrwab9c0apwavi892q"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/abo-abo/swiper")
+ (synopsis "Incremental vertical completion")
+ (description
+ "This package provides @code{ivy-read} as an alternative to
+@code{completing-read} and similar functions. No attempt is made to determine
+the best candidate. Instead, the user can navigate candidates with
+@code{ivy-next-line} and @code{ivy-previous-line}. The matching is done by
+splitting the input text by spaces and re-building it into a regular
+expression.")
+ (license license:gpl3+)))
+
(define-public emacs-clojure-mode
(package
(name "emacs-clojure-mode")