gnu: Add emacs-org-bullets.

Message ID 20160618161329.3403-1-rekado@elephly.net
State New
Headers

Commit Message

Ricardo Wurmus June 18, 2016, 4:13 p.m. UTC
  * gnu/packages/emacs.scm (emacs-org-bullets): New variable.
---
 gnu/packages/emacs.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
  

Comments

Alex Kost June 19, 2016, 5:10 p.m. UTC | #1
Ricardo Wurmus (2016-06-18 19:13 +0300) wrote:

> * gnu/packages/emacs.scm (emacs-org-bullets): New variable.
> ---
>  gnu/packages/emacs.scm | 21 +++++++++++++++++++++
>  1 file changed, 21 insertions(+)
>
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index ecefc97..d524a7c 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -1646,6 +1646,27 @@ that it correctly finds RFCs even when a space appears before the
>  number.")
>      (license license:gpl3+)))
>  
> +(define-public emacs-org-bullets
> +  (package
> +    (name "emacs-org-bullets")
> +    (version "0.2.4")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://github.com/sabof/org-bullets/archive/"
> +                           version ".tar.gz"))
> +       (file-name (string-append name "-" version ".tar.gz"))
> +       (sha256
> +        (base32
> +         "1dyxvpb73vj80v8br2q9rf255hfphrgaw91fbvwdcd735np9pcnh"))))
> +    (build-system emacs-build-system)
> +    (home-page "https://github.com/sabof/org-bullets")
> +    (synopsis "Show bullets in org-mode as UTF-8 characters")
> +    (description
> +     "This package provides an Emacs theme for org-mode causing bullets to be
> +rendered as UTF-8 characters.")

This is not "an Emacs theme".  This package provides a minor mode
(org-bullets-mode), not a theme, so I think it's better to replace
"theme" with "minor mode" here, or something like that.

Otherwise LGTM, thanks!

> +    (license license:gpl3+)))
> +
>  (define-public emacs-zenburn-theme
>    (package
>      (name "emacs-zenburn-theme")
  
Ricardo Wurmus June 20, 2016, 4:30 a.m. UTC | #2
Alex Kost <alezost@gmail.com> writes:

> Ricardo Wurmus (2016-06-18 19:13 +0300) wrote:
>
>> * gnu/packages/emacs.scm (emacs-org-bullets): New variable.
>> ---
>>  gnu/packages/emacs.scm | 21 +++++++++++++++++++++
>>  1 file changed, 21 insertions(+)
>>
>>
>> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
>> index ecefc97..d524a7c 100644
>> --- a/gnu/packages/emacs.scm
>> +++ b/gnu/packages/emacs.scm
>> @@ -1646,6 +1646,27 @@ that it correctly finds RFCs even when a space appears before the
>>  number.")
>>      (license license:gpl3+)))
>>  
>> +(define-public emacs-org-bullets
>> +  (package
>> +    (name "emacs-org-bullets")
>> +    (version "0.2.4")
>> +    (source
>> +     (origin
>> +       (method url-fetch)
>> +       (uri (string-append "https://github.com/sabof/org-bullets/archive/"
>> +                           version ".tar.gz"))
>> +       (file-name (string-append name "-" version ".tar.gz"))
>> +       (sha256
>> +        (base32
>> +         "1dyxvpb73vj80v8br2q9rf255hfphrgaw91fbvwdcd735np9pcnh"))))
>> +    (build-system emacs-build-system)
>> +    (home-page "https://github.com/sabof/org-bullets")
>> +    (synopsis "Show bullets in org-mode as UTF-8 characters")
>> +    (description
>> +     "This package provides an Emacs theme for org-mode causing bullets to be
>> +rendered as UTF-8 characters.")
>
> This is not "an Emacs theme".  This package provides a minor mode
> (org-bullets-mode), not a theme, so I think it's better to replace
> "theme" with "minor mode" here, or something like that.

Okay, will do.  Thanks!

~~ Ricardo
  

Patch

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ecefc97..d524a7c 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1646,6 +1646,27 @@  that it correctly finds RFCs even when a space appears before the
 number.")
     (license license:gpl3+)))
 
+(define-public emacs-org-bullets
+  (package
+    (name "emacs-org-bullets")
+    (version "0.2.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/sabof/org-bullets/archive/"
+                           version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1dyxvpb73vj80v8br2q9rf255hfphrgaw91fbvwdcd735np9pcnh"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/sabof/org-bullets")
+    (synopsis "Show bullets in org-mode as UTF-8 characters")
+    (description
+     "This package provides an Emacs theme for org-mode causing bullets to be
+rendered as UTF-8 characters.")
+    (license license:gpl3+)))
+
 (define-public emacs-zenburn-theme
   (package
     (name "emacs-zenburn-theme")