Commit Message
* gnu/packages/emacs.scm (emacs-company): New variable.
---
gnu/packages/emacs.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
Comments
On 17/06/16 16:12, Ricardo Wurmus wrote:
> * gnu/packages/emacs.scm (emacs-company): New variable.
> ---
> gnu/packages/emacs.scm | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index cb6464d..e4b3097 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -1333,6 +1333,30 @@ view the build status of those servers' build jobs, and possibly to trigger
> build jobs.")
> (license license:gpl3+)))
>
> +(define-public emacs-company
> + (package
> + (name "emacs-company")
> + (version "0.8.12")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "http://elpa.gnu.org/packages/company-"
> + version ".tar"))
> + (sha256
> + (base32
> + "1r7q813rjs4dgknsfqi354ahsvk8k4ld4xh1fkp8lbxb13da6gqx"))))
> + (build-system emacs-build-system)
> + ;; The tests cannot be built because the file "company-tests" is not part
> + ;; of the tarball.
It is part of the GitHub releases though e.g. at
https://github.com/company-mode/company-mode/tree/e085a333867959a1b36015a3ad8e12e5bd6550d9
Would it make sense to source from GitHub instead?
ben
@@ -1333,6 +1333,30 @@ view the build status of those servers' build jobs, and possibly to trigger
build jobs.")
(license license:gpl3+)))
+(define-public emacs-company
+ (package
+ (name "emacs-company")
+ (version "0.8.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://elpa.gnu.org/packages/company-"
+ version ".tar"))
+ (sha256
+ (base32
+ "1r7q813rjs4dgknsfqi354ahsvk8k4ld4xh1fkp8lbxb13da6gqx"))))
+ (build-system emacs-build-system)
+ ;; The tests cannot be built because the file "company-tests" is not part
+ ;; of the tarball.
+ (home-page "http://company-mode.github.io/")
+ (synopsis "Modular text completion framework")
+ (description
+ "Company is a modular completion mechanism. Modules for retrieving
+completion candidates are called back-ends, modules for displaying them are
+front-ends. Company comes with many back-ends, e.g. `company-elisp'. These
+are distributed in separate files and can be used individually.")
+ (license license:gpl3+)))
+
(define-public typo
(package
(name "emacs-typo")