gnu: gnu/packages/emacs.scm add tls for elpa.gnu.org
Commit Message
This patch adds rewrites from http to https for
elpa.gnu.org in gnu/packages/emacs.scm
Split off from this thread:
https://lists.gnu.org/archive/html/guix-devel/2016-06/msg00384.html
From 7195a4446d19fee379e339b65e674413ec4398a7 Mon Sep 17 00:00:00 2001
From: ng0 <ng0@we.make.ritual.n0.is>
Date: Sat, 11 Jun 2016 18:02:40 +0000
Subject: [PATCH] gnu: emacs.scm: Rewrite http to https for elpa.gnu.org
* Change sources with http://elpa.gnu.org/ to
https://elpa.gnu.org/ (uses Lets Encrypt CA)
---
gnu/packages/emacs.scm | 23 ++++++++++++-----------
1 file changed, 12 insertions(+), 11 deletions(-)
--
2.7.3
--
♥Ⓐ ng0
For non-prism friendly talk find me on
psyced.org / loupsycedyglgamf.onion
Comments
On 2016-06-11(06:09:06PM+0000), ng0 wrote:
> This patch adds rewrites from http to https for
> elpa.gnu.org in gnu/packages/emacs.scm
>
> Split off from this thread:
> https://lists.gnu.org/archive/html/guix-devel/2016-06/msg00384.html
>
>
> From 7195a4446d19fee379e339b65e674413ec4398a7 Mon Sep 17 00:00:00 2001
> From: ng0 <ng0@we.make.ritual.n0.is>
> Date: Sat, 11 Jun 2016 18:02:40 +0000
> Subject: [PATCH] gnu: emacs.scm: Rewrite http to https for elpa.gnu.org
>
> * Change sources with http://elpa.gnu.org/ to
> https://elpa.gnu.org/ (uses Lets Encrypt CA)
Can we either
fix up hackage.scm, elpa.scm, and others to only accept https:// for URI
or
change the guix download system to use tls when possible? I imagine
the first one is easier, but I'm not familar with the import systems
yet, so I don't see how to add it in the hackage importers source code.
The ideal goal for gnu/packages/*.scm is to fetch sources through https://
links where ever possible.
> ---
> gnu/packages/emacs.scm | 23 ++++++++++++-----------
> 1 file changed, 12 insertions(+), 11 deletions(-)
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 1f1d201..765747e 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -12,6 +12,7 @@
> ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
> ;;; Copyright © 2016 David Thompson <davet@gnu.org>
> ;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
> +;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -626,7 +627,7 @@ programs.")
> (version "1.0.4")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/let-alist-"
> + (uri (string-append "https://elpa.gnu.org/packages/let-alist-"
> version ".el"))
> (sha256
> (base32
> @@ -655,7 +656,7 @@ programs.")
> (emacs-byte-compile-directory lispdir)
> #t))))
> (native-inputs `(("emacs" ,emacs-minimal)))
> - (home-page "http://elpa.gnu.org/packages/let-alist.html")
> + (home-page "https://elpa.gnu.org/packages/let-alist.html")
> (synopsis "Easily let-bind values of an assoc-list by their names")
> (description
> "This package offers a single Emacs Lisp macro, @code{let-alist}. This
> @@ -988,13 +989,13 @@ mode, Rmail, Gnus, MH-E, and VM). BBDB is fully customizable.")
> (version "1.9")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/async-"
> + (uri (string-append "https://elpa.gnu.org/packages/async-"
> version ".tar"))
> (sha256
> (base32
> "1ip5nc8xyln5szvqwp6wqva9xr84pn8ssn3nnphrszr19y4js2bm"))))
> (build-system emacs-build-system)
> - (home-page "http://elpa.gnu.org/packages/async.html")
> + (home-page "https://elpa.gnu.org/packages/async.html")
> (synopsis "Asynchronous processing in Emacs")
> (description
> "This package provides the ability to call asynchronous functions and
> @@ -1011,7 +1012,7 @@ as a library for other Emacs packages.")
> (origin
> (method url-fetch)
> (uri (string-append
> - "http://elpa.gnu.org/packages/auctex-"
> + "https://elpa.gnu.org/packages/auctex-"
> version
> ".tar"))
> (sha256
> @@ -1258,7 +1259,7 @@ source code using IPython.")
> (version "0.9")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/debbugs-"
> + (uri (string-append "https://elpa.gnu.org/packages/debbugs-"
> version ".tar"))
> (sha256
> (base32
> @@ -1266,7 +1267,7 @@ source code using IPython.")
> (build-system emacs-build-system)
> (propagated-inputs
> `(("emacs-async" ,emacs-async)))
> - (home-page "http://elpa.gnu.org/packages/debbugs.html")
> + (home-page "https://elpa.gnu.org/packages/debbugs.html")
> (synopsis "Access the Debbugs bug tracker in Emacs")
> (description
> "This package lets you access the @uref{http://bugs.gnu.org,GNU Bug
> @@ -1700,7 +1701,7 @@ The purpose of this library is to wrap all the quirks and hassle of
> (version "0.1.1")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/queue-"
> + (uri (string-append "https://elpa.gnu.org/packages/queue-"
> version ".el"))
> (sha256
> (base32
> @@ -1743,7 +1744,7 @@ be removed from the front. This type of data structure is sometimes called an
> (version "1.7.1")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/spinner-"
> + (uri (string-append "https://elpa.gnu.org/packages/spinner-"
> version ".el"))
> (sha256
> (base32
> @@ -1762,13 +1763,13 @@ ongoing operations.")
> (version "2.15")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/seq-"
> + (uri (string-append "https://elpa.gnu.org/packages/seq-"
> version ".tar"))
> (sha256
> (base32
> "09wi1765bmn7i8fg6ajjfaxgs4ipc42d58zx2fdqpidrdg9c7q73"))))
> (build-system emacs-build-system)
> - (home-page "http://elpa.gnu.org/packages/seq.html")
> + (home-page "https://elpa.gnu.org/packages/seq.html")
> (synopsis "Sequence manipulation functions for Emacs")
> (description
> "This Emacs library provides sequence-manipulation functions that
> --
> 2.7.3
>
>
> --
> ♥Ⓐ ng0
> For non-prism friendly talk find me on
> psyced.org / loupsycedyglgamf.onion
> From 7195a4446d19fee379e339b65e674413ec4398a7 Mon Sep 17 00:00:00 2001
> From: ng0 <ng0@we.make.ritual.n0.is>
> Date: Sat, 11 Jun 2016 18:02:40 +0000
> Subject: [PATCH] gnu: emacs.scm: Rewrite http to https for elpa.gnu.org
>
> * Change sources with http://elpa.gnu.org/ to
> https://elpa.gnu.org/ (uses Lets Encrypt CA)
> ---
> gnu/packages/emacs.scm | 23 ++++++++++++-----------
> 1 file changed, 12 insertions(+), 11 deletions(-)
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 1f1d201..765747e 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -12,6 +12,7 @@
> ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
> ;;; Copyright © 2016 David Thompson <davet@gnu.org>
> ;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
> +;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -626,7 +627,7 @@ programs.")
> (version "1.0.4")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/let-alist-"
> + (uri (string-append "https://elpa.gnu.org/packages/let-alist-"
> version ".el"))
> (sha256
> (base32
> @@ -655,7 +656,7 @@ programs.")
> (emacs-byte-compile-directory lispdir)
> #t))))
> (native-inputs `(("emacs" ,emacs-minimal)))
> - (home-page "http://elpa.gnu.org/packages/let-alist.html")
> + (home-page "https://elpa.gnu.org/packages/let-alist.html")
> (synopsis "Easily let-bind values of an assoc-list by their names")
> (description
> "This package offers a single Emacs Lisp macro, @code{let-alist}. This
> @@ -988,13 +989,13 @@ mode, Rmail, Gnus, MH-E, and VM). BBDB is fully customizable.")
> (version "1.9")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/async-"
> + (uri (string-append "https://elpa.gnu.org/packages/async-"
> version ".tar"))
> (sha256
> (base32
> "1ip5nc8xyln5szvqwp6wqva9xr84pn8ssn3nnphrszr19y4js2bm"))))
> (build-system emacs-build-system)
> - (home-page "http://elpa.gnu.org/packages/async.html")
> + (home-page "https://elpa.gnu.org/packages/async.html")
> (synopsis "Asynchronous processing in Emacs")
> (description
> "This package provides the ability to call asynchronous functions and
> @@ -1011,7 +1012,7 @@ as a library for other Emacs packages.")
> (origin
> (method url-fetch)
> (uri (string-append
> - "http://elpa.gnu.org/packages/auctex-"
> + "https://elpa.gnu.org/packages/auctex-"
> version
> ".tar"))
> (sha256
> @@ -1258,7 +1259,7 @@ source code using IPython.")
> (version "0.9")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/debbugs-"
> + (uri (string-append "https://elpa.gnu.org/packages/debbugs-"
> version ".tar"))
> (sha256
> (base32
> @@ -1266,7 +1267,7 @@ source code using IPython.")
> (build-system emacs-build-system)
> (propagated-inputs
> `(("emacs-async" ,emacs-async)))
> - (home-page "http://elpa.gnu.org/packages/debbugs.html")
> + (home-page "https://elpa.gnu.org/packages/debbugs.html")
> (synopsis "Access the Debbugs bug tracker in Emacs")
> (description
> "This package lets you access the @uref{http://bugs.gnu.org,GNU Bug
> @@ -1700,7 +1701,7 @@ The purpose of this library is to wrap all the quirks and hassle of
> (version "0.1.1")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/queue-"
> + (uri (string-append "https://elpa.gnu.org/packages/queue-"
> version ".el"))
> (sha256
> (base32
> @@ -1743,7 +1744,7 @@ be removed from the front. This type of data structure is sometimes called an
> (version "1.7.1")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/spinner-"
> + (uri (string-append "https://elpa.gnu.org/packages/spinner-"
> version ".el"))
> (sha256
> (base32
> @@ -1762,13 +1763,13 @@ ongoing operations.")
> (version "2.15")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/seq-"
> + (uri (string-append "https://elpa.gnu.org/packages/seq-"
> version ".tar"))
> (sha256
> (base32
> "09wi1765bmn7i8fg6ajjfaxgs4ipc42d58zx2fdqpidrdg9c7q73"))))
> (build-system emacs-build-system)
> - (home-page "http://elpa.gnu.org/packages/seq.html")
> + (home-page "https://elpa.gnu.org/packages/seq.html")
> (synopsis "Sequence manipulation functions for Emacs")
> (description
> "This Emacs library provides sequence-manipulation functions that
> --
> 2.7.3
>
--
♥Ⓐ ng0
For non-prism friendly talk find me on
psyced.org / loupsycedyglgamf.onion
I'm getting an error that the patch won't apply. Can you resend it?
Thanks.
On Sat, Jun 11, 2016 at 06:09:06PM +0000, ng0 wrote:
> This patch adds rewrites from http to https for
> elpa.gnu.org in gnu/packages/emacs.scm
>
> Split off from this thread:
> https://lists.gnu.org/archive/html/guix-devel/2016-06/msg00384.html
>
>
> From 7195a4446d19fee379e339b65e674413ec4398a7 Mon Sep 17 00:00:00 2001
> From: ng0 <ng0@we.make.ritual.n0.is>
> Date: Sat, 11 Jun 2016 18:02:40 +0000
> Subject: [PATCH] gnu: emacs.scm: Rewrite http to https for elpa.gnu.org
>
> * Change sources with http://elpa.gnu.org/ to
> https://elpa.gnu.org/ (uses Lets Encrypt CA)
> ---
> gnu/packages/emacs.scm | 23 ++++++++++++-----------
> 1 file changed, 12 insertions(+), 11 deletions(-)
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 1f1d201..765747e 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -12,6 +12,7 @@
> ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
> ;;; Copyright © 2016 David Thompson <davet@gnu.org>
> ;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
> +;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -626,7 +627,7 @@ programs.")
> (version "1.0.4")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/let-alist-"
> + (uri (string-append "https://elpa.gnu.org/packages/let-alist-"
> version ".el"))
> (sha256
> (base32
> @@ -655,7 +656,7 @@ programs.")
> (emacs-byte-compile-directory lispdir)
> #t))))
> (native-inputs `(("emacs" ,emacs-minimal)))
> - (home-page "http://elpa.gnu.org/packages/let-alist.html")
> + (home-page "https://elpa.gnu.org/packages/let-alist.html")
> (synopsis "Easily let-bind values of an assoc-list by their names")
> (description
> "This package offers a single Emacs Lisp macro, @code{let-alist}. This
> @@ -988,13 +989,13 @@ mode, Rmail, Gnus, MH-E, and VM). BBDB is fully customizable.")
> (version "1.9")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/async-"
> + (uri (string-append "https://elpa.gnu.org/packages/async-"
> version ".tar"))
> (sha256
> (base32
> "1ip5nc8xyln5szvqwp6wqva9xr84pn8ssn3nnphrszr19y4js2bm"))))
> (build-system emacs-build-system)
> - (home-page "http://elpa.gnu.org/packages/async.html")
> + (home-page "https://elpa.gnu.org/packages/async.html")
> (synopsis "Asynchronous processing in Emacs")
> (description
> "This package provides the ability to call asynchronous functions and
> @@ -1011,7 +1012,7 @@ as a library for other Emacs packages.")
> (origin
> (method url-fetch)
> (uri (string-append
> - "http://elpa.gnu.org/packages/auctex-"
> + "https://elpa.gnu.org/packages/auctex-"
> version
> ".tar"))
> (sha256
> @@ -1258,7 +1259,7 @@ source code using IPython.")
> (version "0.9")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/debbugs-"
> + (uri (string-append "https://elpa.gnu.org/packages/debbugs-"
> version ".tar"))
> (sha256
> (base32
> @@ -1266,7 +1267,7 @@ source code using IPython.")
> (build-system emacs-build-system)
> (propagated-inputs
> `(("emacs-async" ,emacs-async)))
> - (home-page "http://elpa.gnu.org/packages/debbugs.html")
> + (home-page "https://elpa.gnu.org/packages/debbugs.html")
> (synopsis "Access the Debbugs bug tracker in Emacs")
> (description
> "This package lets you access the @uref{http://bugs.gnu.org,GNU Bug
> @@ -1700,7 +1701,7 @@ The purpose of this library is to wrap all the quirks and hassle of
> (version "0.1.1")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/queue-"
> + (uri (string-append "https://elpa.gnu.org/packages/queue-"
> version ".el"))
> (sha256
> (base32
> @@ -1743,7 +1744,7 @@ be removed from the front. This type of data structure is sometimes called an
> (version "1.7.1")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/spinner-"
> + (uri (string-append "https://elpa.gnu.org/packages/spinner-"
> version ".el"))
> (sha256
> (base32
> @@ -1762,13 +1763,13 @@ ongoing operations.")
> (version "2.15")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/seq-"
> + (uri (string-append "https://elpa.gnu.org/packages/seq-"
> version ".tar"))
> (sha256
> (base32
> "09wi1765bmn7i8fg6ajjfaxgs4ipc42d58zx2fdqpidrdg9c7q73"))))
> (build-system emacs-build-system)
> - (home-page "http://elpa.gnu.org/packages/seq.html")
> + (home-page "https://elpa.gnu.org/packages/seq.html")
> (synopsis "Sequence manipulation functions for Emacs")
> (description
> "This Emacs library provides sequence-manipulation functions that
> --
> 2.7.3
>
>
> --
> ♥Ⓐ ng0
> For non-prism friendly talk find me on
> psyced.org / loupsycedyglgamf.onion
> From 7195a4446d19fee379e339b65e674413ec4398a7 Mon Sep 17 00:00:00 2001
> From: ng0 <ng0@we.make.ritual.n0.is>
> Date: Sat, 11 Jun 2016 18:02:40 +0000
> Subject: [PATCH] gnu: emacs.scm: Rewrite http to https for elpa.gnu.org
>
> * Change sources with http://elpa.gnu.org/ to
> https://elpa.gnu.org/ (uses Lets Encrypt CA)
> ---
> gnu/packages/emacs.scm | 23 ++++++++++++-----------
> 1 file changed, 12 insertions(+), 11 deletions(-)
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 1f1d201..765747e 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -12,6 +12,7 @@
> ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
> ;;; Copyright © 2016 David Thompson <davet@gnu.org>
> ;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
> +;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -626,7 +627,7 @@ programs.")
> (version "1.0.4")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/let-alist-"
> + (uri (string-append "https://elpa.gnu.org/packages/let-alist-"
> version ".el"))
> (sha256
> (base32
> @@ -655,7 +656,7 @@ programs.")
> (emacs-byte-compile-directory lispdir)
> #t))))
> (native-inputs `(("emacs" ,emacs-minimal)))
> - (home-page "http://elpa.gnu.org/packages/let-alist.html")
> + (home-page "https://elpa.gnu.org/packages/let-alist.html")
> (synopsis "Easily let-bind values of an assoc-list by their names")
> (description
> "This package offers a single Emacs Lisp macro, @code{let-alist}. This
> @@ -988,13 +989,13 @@ mode, Rmail, Gnus, MH-E, and VM). BBDB is fully customizable.")
> (version "1.9")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/async-"
> + (uri (string-append "https://elpa.gnu.org/packages/async-"
> version ".tar"))
> (sha256
> (base32
> "1ip5nc8xyln5szvqwp6wqva9xr84pn8ssn3nnphrszr19y4js2bm"))))
> (build-system emacs-build-system)
> - (home-page "http://elpa.gnu.org/packages/async.html")
> + (home-page "https://elpa.gnu.org/packages/async.html")
> (synopsis "Asynchronous processing in Emacs")
> (description
> "This package provides the ability to call asynchronous functions and
> @@ -1011,7 +1012,7 @@ as a library for other Emacs packages.")
> (origin
> (method url-fetch)
> (uri (string-append
> - "http://elpa.gnu.org/packages/auctex-"
> + "https://elpa.gnu.org/packages/auctex-"
> version
> ".tar"))
> (sha256
> @@ -1258,7 +1259,7 @@ source code using IPython.")
> (version "0.9")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/debbugs-"
> + (uri (string-append "https://elpa.gnu.org/packages/debbugs-"
> version ".tar"))
> (sha256
> (base32
> @@ -1266,7 +1267,7 @@ source code using IPython.")
> (build-system emacs-build-system)
> (propagated-inputs
> `(("emacs-async" ,emacs-async)))
> - (home-page "http://elpa.gnu.org/packages/debbugs.html")
> + (home-page "https://elpa.gnu.org/packages/debbugs.html")
> (synopsis "Access the Debbugs bug tracker in Emacs")
> (description
> "This package lets you access the @uref{http://bugs.gnu.org,GNU Bug
> @@ -1700,7 +1701,7 @@ The purpose of this library is to wrap all the quirks and hassle of
> (version "0.1.1")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/queue-"
> + (uri (string-append "https://elpa.gnu.org/packages/queue-"
> version ".el"))
> (sha256
> (base32
> @@ -1743,7 +1744,7 @@ be removed from the front. This type of data structure is sometimes called an
> (version "1.7.1")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/spinner-"
> + (uri (string-append "https://elpa.gnu.org/packages/spinner-"
> version ".el"))
> (sha256
> (base32
> @@ -1762,13 +1763,13 @@ ongoing operations.")
> (version "2.15")
> (source (origin
> (method url-fetch)
> - (uri (string-append "http://elpa.gnu.org/packages/seq-"
> + (uri (string-append "https://elpa.gnu.org/packages/seq-"
> version ".tar"))
> (sha256
> (base32
> "09wi1765bmn7i8fg6ajjfaxgs4ipc42d58zx2fdqpidrdg9c7q73"))))
> (build-system emacs-build-system)
> - (home-page "http://elpa.gnu.org/packages/seq.html")
> + (home-page "https://elpa.gnu.org/packages/seq.html")
> (synopsis "Sequence manipulation functions for Emacs")
> (description
> "This Emacs library provides sequence-manipulation functions that
> --
> 2.7.3
>
On 2016-06-22(09:58:11PM+0300), Efraim Flashner wrote:
> I'm getting an error that the patch won't apply. Can you resend it?
>
> Thanks.
>
>
> On Sat, Jun 11, 2016 at 06:09:06PM +0000, ng0 wrote:
> > This patch adds rewrites from http to https for
> > elpa.gnu.org in gnu/packages/emacs.scm
> >
> > Split off from this thread:
> > https://lists.gnu.org/archive/html/guix-devel/2016-06/msg00384.html
> >
> >
> > From 7195a4446d19fee379e339b65e674413ec4398a7 Mon Sep 17 00:00:00 2001
> > From: ng0 <ng0@we.make.ritual.n0.is>
> > Date: Sat, 11 Jun 2016 18:02:40 +0000
> > Subject: [PATCH] gnu: emacs.scm: Rewrite http to https for elpa.gnu.org
> >
> > * Change sources with http://elpa.gnu.org/ to
> > https://elpa.gnu.org/ (uses Lets Encrypt CA)
Okay.
This is low priority and I will send in new patch(es) like this
once I have time for it - hopefully with the answer of gnu.org
about wether we can or can't fix the http in the header.
--
♥Ⓐ ng0
For non-prism friendly talk find me on
psyced.org / loupsycedyglgamf.onion
From 7195a4446d19fee379e339b65e674413ec4398a7 Mon Sep 17 00:00:00 2001
From: ng0 <ng0@we.make.ritual.n0.is>
Date: Sat, 11 Jun 2016 18:02:40 +0000
Subject: [PATCH] gnu: emacs.scm: Rewrite http to https for elpa.gnu.org
* Change sources with http://elpa.gnu.org/ to
https://elpa.gnu.org/ (uses Lets Encrypt CA)
---
gnu/packages/emacs.scm | 23 ++++++++++++-----------
1 file changed, 12 insertions(+), 11 deletions(-)
@@ -12,6 +12,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
+;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -626,7 +627,7 @@ programs.")
(version "1.0.4")
(source (origin
(method url-fetch)
- (uri (string-append "http://elpa.gnu.org/packages/let-alist-"
+ (uri (string-append "https://elpa.gnu.org/packages/let-alist-"
version ".el"))
(sha256
(base32
@@ -655,7 +656,7 @@ programs.")
(emacs-byte-compile-directory lispdir)
#t))))
(native-inputs `(("emacs" ,emacs-minimal)))
- (home-page "http://elpa.gnu.org/packages/let-alist.html")
+ (home-page "https://elpa.gnu.org/packages/let-alist.html")
(synopsis "Easily let-bind values of an assoc-list by their names")
(description
"This package offers a single Emacs Lisp macro, @code{let-alist}. This
@@ -988,13 +989,13 @@ mode, Rmail, Gnus, MH-E, and VM). BBDB is fully customizable.")
(version "1.9")
(source (origin
(method url-fetch)
- (uri (string-append "http://elpa.gnu.org/packages/async-"
+ (uri (string-append "https://elpa.gnu.org/packages/async-"
version ".tar"))
(sha256
(base32
"1ip5nc8xyln5szvqwp6wqva9xr84pn8ssn3nnphrszr19y4js2bm"))))
(build-system emacs-build-system)
- (home-page "http://elpa.gnu.org/packages/async.html")
+ (home-page "https://elpa.gnu.org/packages/async.html")
(synopsis "Asynchronous processing in Emacs")
(description
"This package provides the ability to call asynchronous functions and
@@ -1011,7 +1012,7 @@ as a library for other Emacs packages.")
(origin
(method url-fetch)
(uri (string-append
- "http://elpa.gnu.org/packages/auctex-"
+ "https://elpa.gnu.org/packages/auctex-"
version
".tar"))
(sha256
@@ -1258,7 +1259,7 @@ source code using IPython.")
(version "0.9")
(source (origin
(method url-fetch)
- (uri (string-append "http://elpa.gnu.org/packages/debbugs-"
+ (uri (string-append "https://elpa.gnu.org/packages/debbugs-"
version ".tar"))
(sha256
(base32
@@ -1266,7 +1267,7 @@ source code using IPython.")
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-async" ,emacs-async)))
- (home-page "http://elpa.gnu.org/packages/debbugs.html")
+ (home-page "https://elpa.gnu.org/packages/debbugs.html")
(synopsis "Access the Debbugs bug tracker in Emacs")
(description
"This package lets you access the @uref{http://bugs.gnu.org,GNU Bug
@@ -1700,7 +1701,7 @@ The purpose of this library is to wrap all the quirks and hassle of
(version "0.1.1")
(source (origin
(method url-fetch)
- (uri (string-append "http://elpa.gnu.org/packages/queue-"
+ (uri (string-append "https://elpa.gnu.org/packages/queue-"
version ".el"))
(sha256
(base32
@@ -1743,7 +1744,7 @@ be removed from the front. This type of data structure is sometimes called an
(version "1.7.1")
(source (origin
(method url-fetch)
- (uri (string-append "http://elpa.gnu.org/packages/spinner-"
+ (uri (string-append "https://elpa.gnu.org/packages/spinner-"
version ".el"))
(sha256
(base32
@@ -1762,13 +1763,13 @@ ongoing operations.")
(version "2.15")
(source (origin
(method url-fetch)
- (uri (string-append "http://elpa.gnu.org/packages/seq-"
+ (uri (string-append "https://elpa.gnu.org/packages/seq-"
version ".tar"))
(sha256
(base32
"09wi1765bmn7i8fg6ajjfaxgs4ipc42d58zx2fdqpidrdg9c7q73"))))
(build-system emacs-build-system)
- (home-page "http://elpa.gnu.org/packages/seq.html")
+ (home-page "https://elpa.gnu.org/packages/seq.html")
(synopsis "Sequence manipulation functions for Emacs")
(description
"This Emacs library provides sequence-manipulation functions that
--
2.7.3