Add zimg.

Message ID 20160529115100.GA23424@debian-netbook
State New
Headers

Commit Message

Efraim Flashner May 29, 2016, 11:51 a.m. UTC
  here's a patch to add zimg, a new dependency for vapoursynth in versions
29 and above.
  

Comments

Ricardo Wurmus May 29, 2016, 6:34 p.m. UTC | #1
Efraim Flashner <efraim@flashner.co.il> writes:

> here's a patch to add zimg, a new dependency for vapoursynth in versions
> 29 and above.

Thanks, this looks good to me.  Too bad the release tarball is not
bootstrapped.

I found that the tests contain third-party libs under Expat license
(e.g. “musl”).  Not sure if this needs to be declared.

~~ Ricardo
  
Efraim Flashner May 30, 2016, 7:21 p.m. UTC | #2
On Sun, May 29, 2016 at 08:34:15PM +0200, Ricardo Wurmus wrote:
> 
> Efraim Flashner <efraim@flashner.co.il> writes:
> 
> > here's a patch to add zimg, a new dependency for vapoursynth in versions
> > 29 and above.
> 
> Thanks, this looks good to me.  Too bad the release tarball is not
> bootstrapped.
> 
> I found that the tests contain third-party libs under Expat license
> (e.g. “musl”).  Not sure if this needs to be declared.
> 
> ~~ Ricardo
> 

I've thought about it, and no one else has chimed in. Its in the test
folder and doesn't affect the rest of the code so I've made a note of it
next to the license field but haven't included it as one of the licenses
for the program.
  
Ricardo Wurmus May 30, 2016, 7:35 p.m. UTC | #3
Efraim Flashner <efraim@flashner.co.il> writes:

> On Sun, May 29, 2016 at 08:34:15PM +0200, Ricardo Wurmus wrote:
>> 
>> Efraim Flashner <efraim@flashner.co.il> writes:
>> 
>> > here's a patch to add zimg, a new dependency for vapoursynth in versions
>> > 29 and above.
>> 
>> Thanks, this looks good to me.  Too bad the release tarball is not
>> bootstrapped.
>> 
>> I found that the tests contain third-party libs under Expat license
>> (e.g. “musl”).  Not sure if this needs to be declared.
>> 
>> ~~ Ricardo
>> 
>
> I've thought about it, and no one else has chimed in. Its in the test
> folder and doesn't affect the rest of the code so I've made a note of it
> next to the license field but haven't included it as one of the licenses
> for the program.

I think that’s reasonable.  Thanks!

~~ Ricardo
  

Patch

diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 3651e97..17d1bdd 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -766,3 +766,35 @@  implementation of the codec specified in the JPEG-2000 Part-1 standard (i.e.,
 ISO/IEC 15444-1).")
     (home-page "https://www.ece.uvic.ca/~frodo/jasper/")
     (license (license:x11-style "file://LICENSE"))))
+
+(define-public zimg
+  (package
+    (name "zimg")
+    (version "2.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://github.com/sekrit-twc/zimg/archive/"
+                            "release-" version ".tar.gz"))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "1hqp1gcsa2zhypms5dnasb1srjgxdqm7cip3w5i571kk9nxkn289"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)))
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'autogen
+           (lambda _
+             (zero? (system* "sh" "autogen.sh")))))))
+    (synopsis "Scaling, colorspace conversion, and dithering library")
+    (description "Zimg implements the commonly required image processing basics
+of scaling, colorspace conversion, and depth conversion.  A simple API enables
+conversion between any supported formats to operate with minimal knowledge from
+the programmer.")
+    (home-page "https://github.com/sekrit-twc/zimg")
+    (license (license:fsf-free "file://COPYING")))) ;WTFPL version 2