[v2] * gnu/packages/xdisorg.scm (rofi): New variable.
Commit Message
From: Danny Milosavljevic <dannym@scratchpost.org>
---
gnu/packages/xdisorg.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)
Comments
On Thu, May 26, 2016 at 02:56:19AM +0200, Danny Milosavljevic wrote:
> +(define-public rofi
[...]
> + (inputs
> + `(("libx11" ,libx11)
> + ("libxinerama" ,libxinerama)
> + ("libxft" ,libxft)
> + ("pango" ,pango)
> + ("cairo" ,cairo)
> + ("glib" ,glib)
> + ("startup-notification" ,startup-notification)
> + ("libxkbcommon" ,libxkbcommon)
> + ("libxcb" ,libxcb)
> + ("xcb-util" ,xcb-util)
> + ("xcb-util-wm" ,xcb-util-wm)))
I wondered about this long list of inputs, so I did this:
$ guix gc --references $(./pre-inst-env guix build rofi)
/gnu/store/52cf2idzxj1kqf6lwxwfc1vlvjrrp5sx-pango-1.40.1
/gnu/store/6qrijb6cfyvs8svacr0l9a75vcpypr5f-glib-2.48.0
/gnu/store/8m00x5x8ykmar27s9248cmhnkdb2n54a-glibc-2.22
/gnu/store/b1yqjimbdh5bf9jnizd4h7yf110744j2-bash-4.3.42
/gnu/store/cp042h32w66hklsafrsd95pgzmrnnkbr-rofi-1.0.1
/gnu/store/fdknlx9f4dbf3xd43fbq1p2l60a4y7fj-xcb-util-0.4.0
/gnu/store/gq3w4clm6lva2bm1g3g71xybxjywcdki-cairo-1.14.6
/gnu/store/jsy847sch7lnxjppkn1s1as22dbx74fx-libxcb-1.11
/gnu/store/q3vxfm6wsiv1krzcpagx9452fr6r55zw-startup-notification-0.12
/gnu/store/v39bh3ln3ncnzhyw0kd12d46kww9747v-gcc-4.9.3-lib
/gnu/store/xqzmjw2b2j5i9pmkjmnjp3dm7hdiqln0-libx11-1.6.3
/gnu/store/y4147j71yb2dyycaa0xys0mbgif1wyfs-libxkbcommon-0.5.0
/gnu/store/zibwcnngq3icn435pkkd5df9lvjc25b3-xcb-util-wm-0.4.1
Since libxft and libxinerama are not referred to by the result of the
build, I removed them from (inputs) in the attached revision.
Can you make sure it still works for you with this change?
@@ -907,3 +907,42 @@ demos. It also acts as a nice screen locker.")
(string-append
"http://metadata.ftp-master.debian.org/changelogs/"
"/main/x/xscreensaver/xscreensaver_5.34-2_copyright")))))
+
+(define-public rofi
+ (package
+ (name "rofi")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/DaveDavenport/rofi/releases/download/" version "/rofi-" version ".tar.xz"))
+ (sha256
+ (base32
+ "01jxml9vk4cw7pngpan7dipmb98s6ibh6f0023lw3hbgxy650637"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'adjust-tests
+ (lambda _
+ (substitute* '("test/helper-expand.c")
+ (("~root") "/root")
+ (("~") "")
+ (("g_get_home_dir \\(\\)") "\"/\"")))))))
+ (home-page "https://davedavenport.github.io/rofi/")
+ (synopsis "Application Launcher")
+ (description "Rofi is a minimalist Application Launcher. It memorizes which applications you regularily use and also allows you to search for an application by name.")
+ (inputs
+ `(("libx11" ,libx11)
+ ("libxinerama" ,libxinerama)
+ ("libxft" ,libxft)
+ ("pango" ,pango)
+ ("cairo" ,cairo)
+ ("glib" ,glib)
+ ("startup-notification" ,startup-notification)
+ ("libxkbcommon" ,libxkbcommon)
+ ("libxcb" ,libxcb)
+ ("xcb-util" ,xcb-util)
+ ("xcb-util-wm" ,xcb-util-wm)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (license license:expat)))