gnu: octave: Update to 4.0.2.

Message ID 20160517204146.0407b6f7@openmailbox.org
State New
Headers

Commit Message

Kei Yamashita May 18, 2016, 12:41 a.m. UTC
  Small update for GNU Octave. Hopefully in the future we can include the
GUI.
  

Comments

David Pirotte May 18, 2016, 2:43 a.m. UTC | #1
Hello,

> Small update for GNU Octave. Hopefully in the future we can include the
> GUI.

	I'm not a guix developer, neither a guix user yet, but I follow #guix and
	this list, to get prepared :) and read good advice and good guile
	scheme techniques...

So, starting with version 4.0.x, octave _does_ include a GUI by default, and it
launches itself using this GUI by default [which is a terrible shame afaic, but
that's not the opinion of the octave developers].

So the GUI is in your package, and people who would want to use octave the good old
way, in a terminal or in emacs inferior mode much launch it with the --no-gui option.

Hope this info is useful,
David
  
Efraim Flashner May 18, 2016, 5:23 p.m. UTC | #2
On Tue, May 17, 2016 at 11:43:01PM -0300, David Pirotte wrote:
> Hello,
> 
> > Small update for GNU Octave. Hopefully in the future we can include the
> > GUI.
> 
> 	I'm not a guix developer, neither a guix user yet, but I follow #guix and
> 	this list, to get prepared :) and read good advice and good guile
> 	scheme techniques...
> 
> So, starting with version 4.0.x, octave _does_ include a GUI by default, and it
> launches itself using this GUI by default [which is a terrible shame afaic, but
> that's not the opinion of the octave developers].
> 
> So the GUI is in your package, and people who would want to use octave the good old
> way, in a terminal or in emacs inferior mode much launch it with the --no-gui option.
> 
> Hope this info is useful,
> David

What toolchain do they use to build the GUI? There isn't anything listed
in the inputs like gtk+-2 (as seems standard for GNU projects).
  
David Pirotte May 18, 2016, 7:31 p.m. UTC | #3
Hi Efraim,

> What toolchain do they use to build the GUI? There isn't anything listed
> in the inputs like gtk+-2 (as seems standard for GNU projects).

Qt4

Here, for info, you may check the debian's stretch [debian testing] Octave 4.0.2-1
package dependencies:

	https://packages.debian.org/stretch/octave

Cheers,
David
  
Efraim Flashner May 19, 2016, 1:35 a.m. UTC | #4
On Tue, May 17, 2016 at 08:41:46PM -0400, Kei Kebreau wrote:
> Small update for GNU Octave. Hopefully in the future we can include the
> GUI.

Looks good!

Pushed in commit b7b27a8f28746a488eeee489c71053059dc5a8dc

> 
> -- 
> Kei (GPG Key: 4096R/E6A5EE3C19467A0D)

> From 278409313dbb4567e68bb9a20c7831d17dbc5353 Mon Sep 17 00:00:00 2001
> From: Kei Yamashita <kei@openmailbox.org>
> Date: Tue, 17 May 2016 20:36:17 -0400
> Subject: [PATCH] gnu: octave: Update to 4.0.2.
> 
> * gnu/packages/maths.scm (octave): Update to 4.0.2.
> ---
>  gnu/packages/maths.scm | 9 +++++++--
>  1 file changed, 7 insertions(+), 2 deletions(-)
> 
> diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
> index a794118..32e72ab 100644
> --- a/gnu/packages/maths.scm
> +++ b/gnu/packages/maths.scm
> @@ -11,6 +11,7 @@
>  ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
>  ;;; Copyright © 2015 Fabian Harfert <fhmgufs@web.de>
>  ;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
> +;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -46,6 +47,7 @@
>    #:use-module (gnu packages cmake)
>    #:use-module (gnu packages compression)
>    #:use-module (gnu packages curl)
> +  #:use-module (gnu packages cyrus-sasl)
>    #:use-module (gnu packages documentation)
>    #:use-module (gnu packages elf)
>    #:use-module (gnu packages flex)
> @@ -79,6 +81,7 @@
>    #:use-module (gnu packages tcl)
>    #:use-module (gnu packages texinfo)
>    #:use-module (gnu packages texlive)
> +  #:use-module (gnu packages tls)
>    #:use-module (gnu packages wxwidgets)
>    #:use-module (gnu packages xml)
>    #:use-module (gnu packages zip)
> @@ -583,7 +586,7 @@ online as well as original implementations of various other algorithms.")
>  (define-public octave
>    (package
>      (name "octave")
> -    (version "4.0.0")
> +    (version "4.0.2")
>      (source
>       (origin
>        (method url-fetch)
> @@ -591,7 +594,7 @@ online as well as original implementations of various other algorithms.")
>                            version ".tar.gz"))
>        (sha256
>         (base32
> -        "101jr9yck798586jz4vkjcgk36zksmxf1pxrzvipgn2xgyay0zjc"))))
> +        "1hdxap3j88rpqjimnfhinym6z73wdi5dfa6fv85c13r1dk9qzk9r"))))
>      (build-system gnu-build-system)
>      (inputs
>       `(("lapack" ,lapack)
> @@ -602,6 +605,7 @@ online as well as original implementations of various other algorithms.")
>         ("arpack" ,arpack-ng)
>         ("curl" ,curl)
>         ("pcre" ,pcre)
> +       ("cyrus-sasl" ,cyrus-sasl)
>         ("fltk" ,fltk)
>         ("fontconfig" ,fontconfig)
>         ("freetype" ,freetype)
> @@ -609,6 +613,7 @@ online as well as original implementations of various other algorithms.")
>         ("libxft" ,libxft)
>         ("mesa" ,mesa)
>         ("glu" ,glu)
> +       ("openssl" ,openssl)
>         ("zlib" ,zlib)))
>      (native-inputs
>       `(("gfortran" ,gfortran)
> -- 
> 2.7.4
>
  

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a794118..32e72ab 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2015 Fabian Harfert <fhmgufs@web.de>
 ;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -46,6 +47,7 @@ 
   #:use-module (gnu packages cmake)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages curl)
+  #:use-module (gnu packages cyrus-sasl)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages elf)
   #:use-module (gnu packages flex)
@@ -79,6 +81,7 @@ 
   #:use-module (gnu packages tcl)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages texlive)
+  #:use-module (gnu packages tls)
   #:use-module (gnu packages wxwidgets)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages zip)
@@ -583,7 +586,7 @@  online as well as original implementations of various other algorithms.")
 (define-public octave
   (package
     (name "octave")
-    (version "4.0.0")
+    (version "4.0.2")
     (source
      (origin
       (method url-fetch)
@@ -591,7 +594,7 @@  online as well as original implementations of various other algorithms.")
                           version ".tar.gz"))
       (sha256
        (base32
-        "101jr9yck798586jz4vkjcgk36zksmxf1pxrzvipgn2xgyay0zjc"))))
+        "1hdxap3j88rpqjimnfhinym6z73wdi5dfa6fv85c13r1dk9qzk9r"))))
     (build-system gnu-build-system)
     (inputs
      `(("lapack" ,lapack)
@@ -602,6 +605,7 @@  online as well as original implementations of various other algorithms.")
        ("arpack" ,arpack-ng)
        ("curl" ,curl)
        ("pcre" ,pcre)
+       ("cyrus-sasl" ,cyrus-sasl)
        ("fltk" ,fltk)
        ("fontconfig" ,fontconfig)
        ("freetype" ,freetype)
@@ -609,6 +613,7 @@  online as well as original implementations of various other algorithms.")
        ("libxft" ,libxft)
        ("mesa" ,mesa)
        ("glu" ,glu)
+       ("openssl" ,openssl)
        ("zlib" ,zlib)))
     (native-inputs
      `(("gfortran" ,gfortran)