[1/1] gnu: Add python-discogs-client.

Message ID 16e16dfe94f31b364a059ded23eda5dcb87ac3d6.1480259653.git.leo@famulari.name
State New
Headers

Commit Message

Leo Famulari Nov. 27, 2016, 3:14 p.m. UTC
  * gnu/packages/music.scm (python-discogs-client,
python2-discogs-client): New variables.
---
 gnu/packages/music.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
  

Comments

Marius Bakke Nov. 27, 2016, 5:30 p.m. UTC | #1
Leo Famulari <leo@famulari.name> writes:

> * gnu/packages/music.scm (python-discogs-client,
> python2-discogs-client): New variables.
> ---
>  gnu/packages/music.scm | 34 ++++++++++++++++++++++++++++++++++
>  1 file changed, 34 insertions(+)

This LGTM. I would de-capitalize "client" in the synopsis, but YMMV :-)
  
Leo Famulari Nov. 27, 2016, 7:50 p.m. UTC | #2
On Sun, Nov 27, 2016 at 06:30:34PM +0100, Marius Bakke wrote:
> Leo Famulari <leo@famulari.name> writes:
> 
> > * gnu/packages/music.scm (python-discogs-client,
> > python2-discogs-client): New variables.
> > ---
> >  gnu/packages/music.scm | 34 ++++++++++++++++++++++++++++++++++
> >  1 file changed, 34 insertions(+)
> 
> This LGTM. I would de-capitalize "client" in the synopsis, but YMMV :-)

You're right. Pushed with that change!
  

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 1887919..7106963 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2421,3 +2421,37 @@  a simulation of an analog Wah pedal with switchless activation."))))
 filters, crossovers, simple gain plugins without zipper noise, switch box
 plugins, a switch trigger, a toggle switch, and a peakmeter.")
       (license license:gpl2+))))
+
+(define-public python-discogs-client
+  (package
+    (name "python-discogs-client")
+    (version "2.2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "discogs-client" version))
+              (sha256
+               (base32
+                "053ld2psh0yj3z0kg6z5bn4y3cr562m727494n0ayhgzbkjbacly"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-oauthlib" ,python-oauthlib)
+       ("python-requests" ,python-requests)))
+    (native-inputs
+     `(("python-six" ,python-six)))
+    (home-page "https://github.com/discogs/discogs_client")
+    (synopsis "Official Python Client for the Discogs API")
+    (description "This is the official Discogs API client for Python. It enables
+you to query the Discogs database for information on artists, releases, labels,
+users, Marketplace listings, and more.  It also supports OAuth 1.0a
+authorization, which allows you to change user data such as profile information,
+collections and wantlists, inventory, and orders.")
+    (license license:bsd-2)
+    (properties `((python2-variant . ,(delay python2-discogs-client))))))
+
+(define-public python2-discogs-client
+  (let ((base (package-with-python2
+               (strip-python2-variant python-discogs-client))))
+    (package (inherit base)
+      (native-inputs
+       `(("python2-setuptools" ,python2-setuptools)
+         ,@(package-native-inputs base))))))