[01/14] gnu: ensure pip and setuptools are installed even for Python 2

Message ID 1475071107-10765-2-git-send-email-h.goebel@crazy-compilers.com
State New
Headers

Commit Message

Hartmut Goebel Sept. 28, 2016, 1:58 p.m. UTC
  * gnu/packages/python.scm (python-2.7): Add "--with-ensurepip=install"
  to configure-flags.
---
 gnu/packages/python.scm | 1 +
 1 file changed, 1 insertion(+)
  

Patch

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 688a5d4..b13e41f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -156,6 +156,7 @@ 
        #:configure-flags
        (list "--enable-shared"                    ;allow embedding
              "--with-system-ffi"                  ;build ctypes
+             "--with-ensurepip=install"           ;install pip and setuptools
              (string-append "LDFLAGS=-Wl,-rpath="
                             (assoc-ref %outputs "out") "/lib"))