[2/2] gnu: Add gnome-mpv.
Commit Message
This patch adds gnome-mpv, a simple GTK+ frontend to the mpv video
player.
Comments
Hi Alex,
> This patch adds gnome-mpv, a simple GTK+ frontend to the mpv video
> player.
Thank you for the patch!
> +(define-public gnome-mpv
> + (package
> + (name "gnome-mpv")
> + (version "0.9")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/gnome-mpv/gnome-mpv/releases/download/v"
> + version "/gnome-mpv-" version ".tar.xz"))
This line looks a bit long to me. Have you checked with “guix lint
gnome-mpv”?
> + (sha256
> + (base32
> + "06pgxl6f3kkgxv8nlmyl7gy3pg55sqf8vgr8m6426mlpm4p3qdn0"))))
> + (native-inputs
> + `(("intltool" ,intltool)
> + ("pkg-config" ,pkg-config)))
> + (inputs
> + `(("gtk+" ,gtk+)
> + ("libepoxy" ,libepoxy)
> + ("mpv" ,mpv)))
> + (build-system glib-or-gtk-build-system)
> + (home-page "https://github.com/gnome-mpv/gnome-mpv")
> + (synopsis "Simple GTK+ frontend for mpv")
> + (description "GNOME MPV is a simple GTK+ frontend for mpv. GNOME MPV
> +interacts with mpv via the client API exported by libmpv, allowing access to
> +mpv's powerful playback capabilities.")
> + (license license:gpl3+)))
> +
The rest looks good to me.
~~ Ricardo
Alex Griffin <a@ajgrf.com> writes:
> This patch adds gnome-mpv, a simple GTK+ frontend to the mpv video
> player.
Thanks!
I notified upstream about the availibility:
https://github.com/gnome-mpv/gnome-mpv/issues/203
From b72a82b9abfe01fa9374d22893cb5a0564eee97e Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Wed, 6 Jul 2016 18:58:17 -0500
Subject: [PATCH 2/2] gnu: Add gnome-mpv.
* gnu/packages/video.scm (gnome-mpv): New variable.
---
gnu/packages/video.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
@@ -33,6 +33,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system python)
#:use-module (guix build-system waf)
#:use-module (gnu packages)
@@ -829,6 +830,33 @@ fork of mplayer2 and MPlayer. It shares some features with the former
projects while introducing many more.")
(license license:gpl2+)))
+(define-public gnome-mpv
+ (package
+ (name "gnome-mpv")
+ (version "0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/gnome-mpv/gnome-mpv/releases/download/v"
+ version "/gnome-mpv-" version ".tar.xz"))
+ (sha256
+ (base32
+ "06pgxl6f3kkgxv8nlmyl7gy3pg55sqf8vgr8m6426mlpm4p3qdn0"))))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("libepoxy" ,libepoxy)
+ ("mpv" ,mpv)))
+ (build-system glib-or-gtk-build-system)
+ (home-page "https://github.com/gnome-mpv/gnome-mpv")
+ (synopsis "Simple GTK+ frontend for mpv")
+ (description "GNOME MPV is a simple GTK+ frontend for mpv. GNOME MPV
+interacts with mpv via the client API exported by libmpv, allowing access to
+mpv's powerful playback capabilities.")
+ (license license:gpl3+)))
+
(define-public libvpx
(package
(name "libvpx")
--
2.9.0