[1/2] gnu: mpv: Enable shared library support.
Commit Message
This patch enables the libmpv shared library, needed by frontends like
gnome-mpv.
Comments
Alex Griffin <a@ajgrf.com> writes:
> This patch enables the libmpv shared library, needed by frontends like
> gnome-mpv.
Looks good to me. Thank you!
~~ Ricardo
On Thu, Jul 07, 2016 at 09:11:06AM +0200, Ricardo Wurmus wrote:
>
> Alex Griffin <a@ajgrf.com> writes:
>
> > This patch enables the libmpv shared library, needed by frontends like
> > gnome-mpv.
>
> Looks good to me. Thank you!
>
> ~~ Ricardo
>
patch pushed!
From 23617cd9805a2aeebf8b86caccfb482b7ba8e8c5 Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Wed, 6 Jul 2016 18:55:54 -0500
Subject: [PATCH 1/2] gnu: mpv: Enable shared library support.
* gnu/packages/video.scm (mpv): Enable shared library support.
---
gnu/packages/video.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
@@ -7,6 +7,7 @@
;;; Copyright © 2015 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -818,7 +819,7 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
(lambda* (#:key inputs #:allow-other-keys)
(copy-file (assoc-ref inputs "waf") "waf")
(setenv "CC" "gcc"))))
- #:configure-flags (list "--enable-zsh-comp")
+ #:configure-flags (list "--enable-libmpv-shared" "--enable-zsh-comp")
;; No check function defined.
#:tests? #f))
(home-page "https://mpv.io/")
--
2.9.0