gnu: wrap-python3: create more symlinks.
Commit Message
* gnu/pyckages/python.csm (wrap-python3): Create symlinks for
pip and python-config, too.
---
gnu/packages/python.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
Comments
Sorry, this patch was accidentaly resend.
Hi Hartmut,
the content of the patch looks good, but I cannot apply it with "git am";
is it relative to an older git commit? I could correct it myself, but
then you would disappear as an author.
Andreas
Hello Andreas,
Am 15.06.2016 um 16:27 schrieb Andreas Enge:
> the content of the patch looks good, but I cannot apply it with "git am";
> is it relative to an older git commit? I could correct it myself, but
> then you would disappear as an author.
I've jsut send an updated version of the patch. I'd appreciate if you
could take care of it.
Hello Hartmut,
On Fri, Jun 17, 2016 at 09:45:22PM +0200, Hartmut Goebel wrote:
> I've jsut send an updated version of the patch. I'd appreciate if you
> could take care of it.
thanks a lot! I applied it locally and was about to push it to master,
when I started to wonder:
$ ./pre-inst-env guix refresh -l python-wrapper
Building the following 558 packages would ensure 1569 dependent packages are rebuilt
This is maybe too much right now; question to those who suffer the most from
core-updates: Should I push it to core-updates-next? This patch is nice to
have, but probably not very urgent.
Andreas
On Mon, Jun 20, 2016 at 11:10:20AM +0200, Andreas Enge wrote:
> This is maybe too much right now; question to those who suffer the most from
> core-updates: Should I push it to core-updates-next? This patch is nice to
> have, but probably not very urgent.
I just pushed to core-updates-next.
Andreas
@@ -18,6 +18,7 @@
;;; Copyright © 2015 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2015, 2016 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2016 Danny Milosavljevic <dannym+a@scratchpost.org>
+;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -334,8 +335,8 @@ data types.")
(lambda (old new)
(symlink (string-append python old)
(string-append bin "/" new)))
- `("python3" ,"pydoc3" ,"idle3")
- `("python" ,"pydoc" ,"idle"))))))
+ `("python3" ,"pydoc3" ,"idle3" ,"pip3" ,"python3-config")
+ `("python" ,"pydoc" ,"idle" ,"pip" ,"python-config"))))))
(synopsis "Wrapper for the Python 3 commands")
(description
"This package provides wrappers for the commands of Python@tie{}3.x such