[08/11] gnu: libtool: support cross-libtool mingw.

Message ID 1462740169-15029-9-git-send-email-janneke@gnu.org
State New
Headers

Commit Message

Jan Nieuwenhuizen May 8, 2016, 8:42 p.m. UTC
  * gnu/packages/patches/libtool-mingw.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/autotools.scm (libtool): Support cross-libtool for mingw.
---
 gnu/packages/autotools.scm               |  3 ++-
 gnu/packages/patches/libtool-mingw.patch | 40 ++++++++++++++++++++++++++++++++
 2 files changed, 42 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/libtool-mingw.patch
  

Comments

Andy Wingo May 9, 2016, 7:39 a.m. UTC | #1
On Sun 08 May 2016 22:42, Jan Nieuwenhuizen <janneke@gnu.org> writes:

> diff --git a/gnu/packages/patches/libtool-mingw.patch b/gnu/packages/patches/libtool-mingw.patch
> new file mode 100644
> index 0000000..1246bd7
> --- /dev/null
> +++ b/gnu/packages/patches/libtool-mingw.patch
> @@ -0,0 +1,40 @@
> +I do not know why stat (and other functions here) get #define'd to their
> +underscore variants; I find no apparent need or rationale for that.  However,
> +redefining stat also impacts struct stat, breaking lstat's signature.  That is
> +fixed be #define'ing lstat along.
> +
> +Jan Nieuwenhuizen
> +
> +Upstream status: not yet presented upstream.
> +
> +--- libtool-2.4.6/build-aux/ltmain.in~	2015-02-06 13:57:56.000000000 +0100
> ++++ libtool-2.4.6/build-aux/ltmain.in	2016-05-06 07:46:29.425142546 +0200
> +@@ -3658,12 +3658,10 @@
> + #if defined _MSC_VER
> + # define setmode _setmode
> +-# define stat    _stat
> + # define chmod   _chmod
> + # define getcwd  _getcwd
> + # define putenv  _putenv
> + # define S_IXUSR _S_IEXEC
> + #elif defined __MINGW32__
> + # define setmode _setmode
> +-# define stat    _stat
> + # define chmod   _chmod
> + # define getcwd  _getcwd

This doesn't look right to me.  Stat was actually the first of this set
to be added to the weird define list, via:

    commit 781fc82e1b2bceaa5c55388d6ab1d1744663f992
    Author: Peter Rosin <peda@lysator.liu.se>
    Date:   Sun Jul 22 17:57:10 2007 +0000

        * libltdl/config/ltmain.m4sh (func_emit_cwrapperexe_src): Add
        support for Microsoft Visual C. Also, older MinGW versions
        seem to need stdint.h to find intptr_t.

And there does appear to exist "struct _stat" in the API
(https://msdn.microsoft.com/en-us/library/14h5k7ff.aspx).  Does it mean
that "lstat" is coming from somewhere else (i.e. not the system libc),
expecting to have a "struct stat" as an argument?  I don't know very
much about this stuff but this change looks fishy to me.

Andy
  

Patch

diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index ddc628d..30c0482 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -272,7 +272,8 @@  Makefile, simplifying the entire process for the developer.")
               (sha256
                (base32
                 "0vxj52zm709125gwv9qqlw02silj8bnjnh4y07arrz60r31ai1vw"))
-              (patches (search-patches "libtool-skip-tests2.patch"))))
+              (patches (search-patches "libtool-skip-tests2.patch"
+                                       "libtool-mingw.patch"))))
     (build-system gnu-build-system)
     (propagated-inputs `(("m4" ,m4)))
     (native-inputs `(("m4" ,m4)
diff --git a/gnu/packages/patches/libtool-mingw.patch b/gnu/packages/patches/libtool-mingw.patch
new file mode 100644
index 0000000..1246bd7
--- /dev/null
+++ b/gnu/packages/patches/libtool-mingw.patch
@@ -0,0 +1,40 @@ 
+I do not know why stat (and other functions here) get #define'd to their
+underscore variants; I find no apparent need or rationale for that.  However,
+redefining stat also impacts struct stat, breaking lstat's signature.  That is
+fixed be #define'ing lstat along.
+
+Jan Nieuwenhuizen
+
+Upstream status: not yet presented upstream.
+
+--- libtool-2.4.6/build-aux/ltmain.in~	2015-02-06 13:57:56.000000000 +0100
++++ libtool-2.4.6/build-aux/ltmain.in	2016-05-06 07:46:29.425142546 +0200
+@@ -3658,12 +3658,10 @@
+ #if defined _MSC_VER
+ # define setmode _setmode
+-# define stat    _stat
+ # define chmod   _chmod
+ # define getcwd  _getcwd
+ # define putenv  _putenv
+ # define S_IXUSR _S_IEXEC
+ #elif defined __MINGW32__
+ # define setmode _setmode
+-# define stat    _stat
+ # define chmod   _chmod
+ # define getcwd  _getcwd
+--- libtool-2.4.6/build-aux/ltmain.sh~	2015-02-15 17:15:12.000000000 +0100
++++ libtool-2.4.6/build-aux/ltmain.sh	2016-05-06 08:31:53.854857844 +0200
+@@ -5569,6 +5569,5 @@
+ /* portability defines, excluding path handling macros */
+ #if defined _MSC_VER
+ # define setmode _setmode
+-# define stat    _stat
+ # define chmod   _chmod
+ # define getcwd  _getcwd
+@@ -5576,6 +5577,5 @@
+ # define S_IXUSR _S_IEXEC
+ #elif defined __MINGW32__
+ # define setmode _setmode
+-# define stat    _stat
+ # define chmod   _chmod
+ # define getcwd  _getcwd