[2/4] gnu: mu: Install emacs files in a proper place.

Message ID 1462702911-18777-3-git-send-email-alezost@gmail.com
State New
Headers

Commit Message

Alex Kost May 8, 2016, 10:21 a.m. UTC
  * gnu/packages/mail.scm (mu)[arguments]: Add 'patch-configure.ac' phase
  to avoid adding "mu4e" sub-directory to 'lispdir' variable.
---
 gnu/packages/mail.scm | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)
  

Comments

Ludovic Courtès May 9, 2016, 8:16 p.m. UTC | #1
Alex Kost <alezost@gmail.com> skribis:

> * gnu/packages/mail.scm (mu)[arguments]: Add 'patch-configure.ac' phase
>   to avoid adding "mu4e" sub-directory to 'lispdir' variable.

[...]

> +           ;; By default, elisp code goes to "share/emacs/site-lisp/mu4e",
> +           ;; so our Emacs package can't find it.  Setting "--with-lispdir"

Should be “--lispdir”, I think.

Otherwise LGTM!
  
Alex Kost May 10, 2016, 8:21 a.m. UTC | #2
Ludovic Courtès (2016-05-09 23:16 +0300) wrote:

> Alex Kost <alezost@gmail.com> skribis:
>
>> * gnu/packages/mail.scm (mu)[arguments]: Add 'patch-configure.ac' phase
>>   to avoid adding "mu4e" sub-directory to 'lispdir' variable.
>
> [...]
>
>> +           ;; By default, elisp code goes to "share/emacs/site-lisp/mu4e",
>> +           ;; so our Emacs package can't find it.  Setting "--with-lispdir"
>
> Should be “--lispdir”, I think.

No, it is literally called “--with-lispdir”.  Look at AM_PATH_LISPDIR in
(info "(automake) Public Macros")
  
Ludovic Courtès May 10, 2016, 1:23 p.m. UTC | #3
Alex Kost <alezost@gmail.com> skribis:

> Ludovic Courtès (2016-05-09 23:16 +0300) wrote:
>
>> Alex Kost <alezost@gmail.com> skribis:
>>
>>> * gnu/packages/mail.scm (mu)[arguments]: Add 'patch-configure.ac' phase
>>>   to avoid adding "mu4e" sub-directory to 'lispdir' variable.
>>
>> [...]
>>
>>> +           ;; By default, elisp code goes to "share/emacs/site-lisp/mu4e",
>>> +           ;; so our Emacs package can't find it.  Setting "--with-lispdir"
>>
>> Should be “--lispdir”, I think.
>
> No, it is literally called “--with-lispdir”.  Look at AM_PATH_LISPDIR in
> (info "(automake) Public Macros")

Indeed, I stand corrected!  :-)

Ludo’.
  

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 59ddd41..48379f2 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -367,7 +367,16 @@  repository and Maildir/IMAP as LOCAL repository.")
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'autoreconf
+         (add-after 'unpack 'patch-configure.ac
+           ;; By default, elisp code goes to "share/emacs/site-lisp/mu4e",
+           ;; so our Emacs package can't find it.  Setting "--with-lispdir"
+           ;; configure flag doesn't help because "mu4e" will be added to
+           ;; the lispdir anyway, so we have to modify "configure.ac".
+           (lambda _
+             (substitute* "configure.ac"
+               (("^ +lispdir=.*") ""))
+             #t))
+         (add-after 'patch-configure.ac 'autoreconf
            (lambda _
              (zero? (system* "autoreconf" "-vi"))))
          (add-before 'check 'check-tz-setup