[3/3] gnu: Add emacs-ledger-mode.
Commit Message
On Sat, May 7, 2016, at 05:23 PM, Leo Famulari wrote:
> Somebody else will have to test that this works; I don't know enough
> about Emacs to try it.
Well it seems to work on my machine, but I guess the whole point of code
review is that somebody checks it other than me.
> Would it be appropriate to use (package-version ledger) and
> (package-source ledger), as in the package definition of tocc?
>
> That way, updating ledger would automatically update emacs-ledger-mode
> as well.
Good idea, done.
From fe7cee618e43bfdba7e39d058676429235a17c56 Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Sat, 7 May 2016 12:22:15 -0500
Subject: [PATCH 3/3] gnu: Add emacs-ledger-mode.
* gnu/packages/emacs.scm (emacs-ledger-mode): New variable.
---
gnu/packages/emacs.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
@@ -7,6 +7,7 @@
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Nils Gillmann <niasterisk@grrlz.net>
;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
+;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -63,6 +64,7 @@
#:use-module (gnu packages scheme)
#:use-module (gnu packages xiph)
#:use-module (gnu packages mp3)
+ #:use-module (gnu packages finance)
#:use-module (guix utils)
#:use-module (srfi srfi-1))
@@ -1559,3 +1561,26 @@ to recognize a name like \"RFC 1234\". This package enhances ffap so
that it correctly finds RFCs even when a space appears before the
number.")
(license license:gpl3+)))
+
+(define-public emacs-ledger-mode
+ (package
+ (name "emacs-ledger-mode")
+ (version (package-version ledger))
+ (source (package-source ledger))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'elisp-subdir
+ (lambda _
+ (begin (chdir "lisp")
+ (delete-file "CMakeLists.txt"))
+ #t)))))
+ (home-page "http://ledger-cli.org/")
+ (synopsis "Emacs mode for working with \"ledger\" accounting data")
+ (description
+ "Ledger is a powerful, double-entry accounting system that is
+ accessed from the UNIX command-line. This package contains an
+ Emacs mode for manipulating ledger's text-based file format,
+ running reports on it, reconciling its accounts, and more.")
+ (license license:gpl2+)))
--
2.7.4