diff mbox

Increase minimum Linux kernel version to 2.6.32

Message ID Pine.LNX.4.64.1403271250210.31497@digraph.polyomino.org.uk
State Committed
Headers show

Commit Message

Joseph Myers March 27, 2014, 12:54 p.m. UTC
This patch, relative to a tree with
<https://sourceware.org/ml/libc-alpha/2014-03/msg00585.html> and
<https://sourceware.org/ml/libc-alpha/2014-03/msg00835.html> (both
pending review for MicroBlaze) applied, increases the minimum Linux
kernel version for glibc to 2.6.32, as discussed in the thread
starting at
<https://sourceware.org/ml/libc-alpha/2014-01/msg00511.html>.

This patch just does the minimal change to arch_minimum_kernel
settings (and LIBC_LINUX_VERSION, which determines the minimum kernel
headers version, as it doesn't make sense for that to be older than
the minimum kernel that can be used at runtime).  Followups would be
expected to do, roughly and not necessarily precisely in this order:

* Remove __LINUX_KERNEL_VERSION checks in kernel-features.h files
  where those checks are always true / always false for kernels 2.6.32
  and above.

* Otherwise simplify/improve conditionals in those files (for example,
  where defining once in the main file then undefining in
  architecture-specific files makes things clearer than having lots of
  separate definitions of the same macro), possibly fixing in the
  process cases where a macro should optimally have been defined for a
  given architecture but wasn't.  (In the review in preparation for
  this version increase I checked what the right conditions should be
  for all macros in the main kernel-features.h whose definitions there
  would have been affected by the increase - but I only fixed that
  subset of the issues found where --enable-kernel=2.6.32 would have
  caused a kernel feature to be wrongly assumed to be present, not any
  cases where a feature is not assumed but could be assumed.)

* Remove conditionals on __ASSUME_* where they can now be taken to be
  always-true, and the definitions when the macros are only used in
  Linux-specific files.

* Split more architectures out of the main kernel-features.h (like
  ex-ports architectures), once various of the architecture
  conditionals there have been eliminated so the new
  architecture-specific files are no larger than actually necessary.

Tested x86_64.

2014-03-27  Joseph Myers  <joseph@codesourcery.com>

	[BZ #9894]
	* sysdeps/unix/sysv/linux/configure.ac (LIBC_LINUX_VERSION):
	Change to 2.6.32.
	(arch_minimum_kernel): Change all 2.6.16 settings to 2.6.32.
	* sysdeps/unix/sysv/linux/configure: Regenerated.
	* sysdeps/unix/sysv/linux/microblaze/configure.ac: Remove file.
	* sysdeps/unix/sysv/linux/microblaze/configure: Likewise.
	* sysdeps/unix/sysv/linux/tile/configure.ac: Likewise.
	* sysdeps/unix/sysv/linux/tile/configure: Likewise.
	* README: Update reference to required Linux kernel version.
	* manual/install.texi (Linux): Update reference to required Linux
	kernel headers version.
	* INSTALL: Regenerated.

Comments

Joseph Myers March 31, 2014, 2:09 p.m. UTC | #1
On Thu, 27 Mar 2014, Joseph S. Myers wrote:

> This patch, relative to a tree with
> <https://sourceware.org/ml/libc-alpha/2014-03/msg00585.html> and
> <https://sourceware.org/ml/libc-alpha/2014-03/msg00835.html> (both
> pending review for MicroBlaze) applied, increases the minimum Linux
> kernel version for glibc to 2.6.32, as discussed in the thread
> starting at
> <https://sourceware.org/ml/libc-alpha/2014-01/msg00511.html>.

Those dependencies are now in, so this patch 
<https://sourceware.org/ml/libc-alpha/2014-03/msg00881.html> should not 
now cause any kernel features to be assumed that are not in fact in 2.6.32 
(at least for __ASSUME_* mentioned in the main kernel-features.h as 
appearing some time between 2.6.16 and 2.6.32, I didn't check 
architecture-specific __ASSUME_* macros).
Joseph Myers April 22, 2014, 9:24 p.m. UTC | #2
Ping.  This patch 
<https://sourceware.org/ml/libc-alpha/2014-03/msg00881.html> is pending 
review.
Joseph Myers April 29, 2014, 9:05 p.m. UTC | #3
Ping^2.  This patch 
<https://sourceware.org/ml/libc-alpha/2014-03/msg00881.html> is still 
pending review.
Adhemerval Zanella Netto April 30, 2014, 1:58 p.m. UTC | #4
On 29-04-2014 18:05, Joseph S. Myers wrote:
> Ping^2.  This patch 
> <https://sourceware.org/ml/libc-alpha/2014-03/msg00881.html> is still 
> pending review.
>
LGTM, thanks.
diff mbox

Patch

diff --git a/INSTALL b/INSTALL
index 13fb678..f49fad4 100644
--- a/INSTALL
+++ b/INSTALL
@@ -389,7 +389,7 @@  Specific advice for GNU/Linux systems
 =====================================
 
 If you are installing the GNU C Library on GNU/Linux systems, you need
-to have the header files from a 2.6.19.1 or newer kernel around for
+to have the header files from a 2.6.32 or newer kernel around for
 reference.  These headers must be installed using `make
 headers_install'; the headers present in the kernel source directory
 are not suitable for direct use by the GNU C Library.  You do not need
diff --git a/NEWS b/NEWS
index 895c640..cfd0f5a 100644
--- a/NEWS
+++ b/NEWS
@@ -14,6 +14,9 @@  Version 2.20
   16639, 16642, 16649, 16670, 16674, 16677, 16680, 16683, 16689, 16695,
   16701, 16706, 16707, 16712, 16713, 16714, 16731, 16743, 16758.
 
+* The minimum Linux kernel version that this version of the GNU C Library
+  can be used with is 2.6.32.
+
 * Running the testsuite no longer terminates as soon as a test fails.
   Instead, a file tests.sum (xtests.sum from "make xcheck") is generated,
   with PASS or FAIL lines for individual tests.  A summary of the results is
diff --git a/README b/README
index f0e0628..90ea24f 100644
--- a/README
+++ b/README
@@ -17,7 +17,7 @@  GNU/Hurd support requires out-of-tree patches that will eventually be
 incorporated into an official GNU C Library release.
 
 When working with Linux kernels, this version of the GNU C Library
-requires Linux kernel version 2.6.16 or later.
+requires Linux kernel version 2.6.32 or later.
 
 Also note that the shared version of the libgcc_s library must be
 installed for the pthread library to work correctly.
diff --git a/manual/install.texi b/manual/install.texi
index d2b8c1e..d7da02b 100644
--- a/manual/install.texi
+++ b/manual/install.texi
@@ -445,7 +445,7 @@  patches, although we try to avoid this.
 @cindex kernel header files
 
 If you are installing @theglibc{} on @gnulinuxsystems{}, you need to have
-the header files from a 2.6.19.1 or newer kernel around for reference.
+the header files from a 2.6.32 or newer kernel around for reference.
 These headers must be installed using @samp{make headers_install}; the
 headers present in the kernel source directory are not suitable for
 direct use by @theglibc{}.  You do not need to use that kernel, just have
diff --git a/sysdeps/unix/sysv/linux/configure b/sysdeps/unix/sysv/linux/configure
index d5ee4ef..fb2e343 100644
--- a/sysdeps/unix/sysv/linux/configure
+++ b/sysdeps/unix/sysv/linux/configure
@@ -174,33 +174,33 @@  $as_echo "$ac_cv_path_EGREP" >&6; }
 
 { $as_echo "$as_me:${as_lineno-$LINENO}: checking installed Linux kernel header files" >&5
 $as_echo_n "checking installed Linux kernel header files... " >&6; }
-if ${libc_cv_linux2619+:} false; then :
+if ${libc_cv_linux2632+:} false; then :
   $as_echo_n "(cached) " >&6
 else
   cat confdefs.h - <<_ACEOF >conftest.$ac_ext
 /* end confdefs.h.  */
 #include <linux/version.h>
-#if !defined LINUX_VERSION_CODE || LINUX_VERSION_CODE <  (2 *65536+ 6 *256+ 19) /* 2.6.19 */
+#if !defined LINUX_VERSION_CODE || LINUX_VERSION_CODE <  (2 *65536+ 6 *256+ 32) /* 2.6.32 */
 eat flaming death
 #endif
 _ACEOF
 if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
   $EGREP "eat flaming death" >/dev/null 2>&1; then :
-  libc_cv_linux2619='TOO OLD!'
+  libc_cv_linux2632='TOO OLD!'
 else
-  libc_cv_linux2619='2.6.19 or later'
+  libc_cv_linux2632='2.6.32 or later'
 fi
 rm -f conftest*
 
 fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $libc_cv_linux2619" >&5
-$as_echo "$libc_cv_linux2619" >&6; }
-if test "$libc_cv_linux2619" != '2.6.19 or later'; then
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $libc_cv_linux2632" >&5
+$as_echo "$libc_cv_linux2632" >&6; }
+if test "$libc_cv_linux2632" != '2.6.32 or later'; then
   as_fn_error $? "GNU libc requires kernel header files from
-Linux 2.6.19 or later to be installed before configuring.
+Linux 2.6.32 or later to be installed before configuring.
 The kernel header files are found usually in /usr/include/asm and
 /usr/include/linux; make sure these directories use files from
-Linux 2.6.19 or later.  This check uses <linux/version.h>, so
+Linux 2.6.32 or later.  This check uses <linux/version.h>, so
 make sure that file was built correctly when installing the kernel header
 files.  To use kernel headers not from /usr/include/linux, use the
 configure option --with-headers." "$LINENO" 5
@@ -216,37 +216,37 @@  test -n "$arch_minimum_kernel" ||
 case "$machine" in
   i386*)
     libc_cv_gcc_unwind_find_fde=yes
-    arch_minimum_kernel=2.6.16
+    arch_minimum_kernel=2.6.32
     ;;
   x86_64/x32)
     arch_minimum_kernel=3.4.0
     ;;
   powerpc/powerpc32*)
     libc_cv_gcc_unwind_find_fde=yes
-    arch_minimum_kernel=2.6.16
+    arch_minimum_kernel=2.6.32
     ;;
   s390/s390-32)
     libc_cv_gcc_unwind_find_fde=yes
-    arch_minimum_kernel=2.6.16
+    arch_minimum_kernel=2.6.32
     ;;
   s390/s390-64)
     libc_cv_gcc_unwind_find_fde=yes
-    arch_minimum_kernel=2.6.16
+    arch_minimum_kernel=2.6.32
     ;;
   sh*)
-    arch_minimum_kernel=2.6.16
+    arch_minimum_kernel=2.6.32
     libc_cv_gcc_unwind_find_fde=yes
     ;;
   sparc/sparc64*)
     libc_cv_gcc_unwind_find_fde=yes
-    arch_minimum_kernel=2.6.16
+    arch_minimum_kernel=2.6.32
     ;;
   sparc*)
     libc_cv_gcc_unwind_find_fde=yes
-    arch_minimum_kernel=2.6.16
+    arch_minimum_kernel=2.6.32
     ;;
   *)
-    arch_minimum_kernel=2.6.16
+    arch_minimum_kernel=2.6.32
     ;;
 esac
 if test -n "$minimum_kernel"; then
diff --git a/sysdeps/unix/sysv/linux/configure.ac b/sysdeps/unix/sysv/linux/configure.ac
index 90cbf48..21c355b 100644
--- a/sysdeps/unix/sysv/linux/configure.ac
+++ b/sysdeps/unix/sysv/linux/configure.ac
@@ -5,7 +5,7 @@  GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
 # existing system library, because we are the only system library.
 inhibit_glue=yes
 
-define([LIBC_LINUX_VERSION],[2.6.19])dnl
+define([LIBC_LINUX_VERSION],[2.6.32])dnl
 if test -n "$sysheaders"; then
   OLD_CPPFLAGS=$CPPFLAGS
   CPPFLAGS="$CPPFLAGS $SYSINCLUDES"
@@ -41,37 +41,37 @@  test -n "$arch_minimum_kernel" ||
 case "$machine" in
   i386*)
     libc_cv_gcc_unwind_find_fde=yes
-    arch_minimum_kernel=2.6.16
+    arch_minimum_kernel=2.6.32
     ;;
   x86_64/x32)
     arch_minimum_kernel=3.4.0
     ;;
   powerpc/powerpc32*)
     libc_cv_gcc_unwind_find_fde=yes
-    arch_minimum_kernel=2.6.16
+    arch_minimum_kernel=2.6.32
     ;;
   s390/s390-32)
     libc_cv_gcc_unwind_find_fde=yes
-    arch_minimum_kernel=2.6.16
+    arch_minimum_kernel=2.6.32
     ;;
   s390/s390-64)
     libc_cv_gcc_unwind_find_fde=yes
-    arch_minimum_kernel=2.6.16
+    arch_minimum_kernel=2.6.32
     ;;
   sh*)
-    arch_minimum_kernel=2.6.16
+    arch_minimum_kernel=2.6.32
     libc_cv_gcc_unwind_find_fde=yes
     ;;
   sparc/sparc64*)
     libc_cv_gcc_unwind_find_fde=yes
-    arch_minimum_kernel=2.6.16
+    arch_minimum_kernel=2.6.32
     ;;
   sparc*)
     libc_cv_gcc_unwind_find_fde=yes
-    arch_minimum_kernel=2.6.16
+    arch_minimum_kernel=2.6.32
     ;;
   *)
-    arch_minimum_kernel=2.6.16
+    arch_minimum_kernel=2.6.32
     ;;
 esac
 if test -n "$minimum_kernel"; then
diff --git a/sysdeps/unix/sysv/linux/microblaze/configure b/sysdeps/unix/sysv/linux/microblaze/configure
deleted file mode 100644
index 0866388..0000000
--- a/sysdeps/unix/sysv/linux/microblaze/configure
+++ /dev/null
@@ -1,4 +0,0 @@ 
-# This file is generated from configure.ac by Autoconf.  DO NOT EDIT!
- # Local configure fragment for sysdeps/unix/sysv/linux/microblaze.
-
-arch_minimum_kernel=2.6.30
diff --git a/sysdeps/unix/sysv/linux/microblaze/configure.ac b/sysdeps/unix/sysv/linux/microblaze/configure.ac
deleted file mode 100644
index f283d37..0000000
--- a/sysdeps/unix/sysv/linux/microblaze/configure.ac
+++ /dev/null
@@ -1,4 +0,0 @@ 
-GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
-# Local configure fragment for sysdeps/unix/sysv/linux/microblaze.
-
-arch_minimum_kernel=2.6.30
diff --git a/sysdeps/unix/sysv/linux/tile/configure b/sysdeps/unix/sysv/linux/tile/configure
deleted file mode 100644
index 02f6c8c..0000000
--- a/sysdeps/unix/sysv/linux/tile/configure
+++ /dev/null
@@ -1,4 +0,0 @@ 
-# This file is generated from configure.ac by Autoconf.  DO NOT EDIT!
- # Local configure fragment for sysdeps/unix/sysv/linux/tile.
-
-arch_minimum_kernel=2.6.32
diff --git a/sysdeps/unix/sysv/linux/tile/configure.ac b/sysdeps/unix/sysv/linux/tile/configure.ac
deleted file mode 100644
index b983e28..0000000
--- a/sysdeps/unix/sysv/linux/tile/configure.ac
+++ /dev/null
@@ -1,4 +0,0 @@ 
-GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
-# Local configure fragment for sysdeps/unix/sysv/linux/tile.
-
-arch_minimum_kernel=2.6.32