diff mbox

[committed] Update NEWS with binutils version requirement for static PIE, support

Message ID 5A65D0C2.6020109@arm.com
State Committed
Headers show

Commit Message

Szabolcs Nagy Jan. 22, 2018, 11:53 a.m. UTC

Comments

Andreas Schwab Jan. 22, 2018, 3:20 p.m. UTC | #1
On Jan 22 2018, Szabolcs Nagy <szabolcs.nagy@arm.com> wrote:

> @@ -16,7 +16,8 @@ Major new features:
>    memory and performance.  When the library is built with --enable-static-pie
>    the resulting libc.a is usable with GCC 8 and above to create static PIE
>    executables using the GCC option '-static-pie'.  This feature is currently
> -  supported on i386, x86_64, x32 and aarch64.
> +  supported on i386, x86_64 and x32 with binutils >=2.29, and on aarch64 with

"2.29 or later"

> +  binutils >=2.30.

"2.30 or later"

Andreas.
diff mbox

Patch

From 6c2374c0323d8e9d831f01456bd5efca4b2bb6ef Mon Sep 17 00:00:00 2001
From: Szabolcs Nagy <szabolcs.nagy@arm.com>
Date: Mon, 22 Jan 2018 10:22:24 +0000
Subject: [PATCH] Update NEWS with binutils version requirement for static PIE
 support

---
 NEWS | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/NEWS b/NEWS
index dd8b7956b2..d8f99b45e2 100644
--- a/NEWS
+++ b/NEWS
@@ -16,7 +16,8 @@  Major new features:
   memory and performance.  When the library is built with --enable-static-pie
   the resulting libc.a is usable with GCC 8 and above to create static PIE
   executables using the GCC option '-static-pie'.  This feature is currently
-  supported on i386, x86_64, x32 and aarch64.
+  supported on i386, x86_64 and x32 with binutils >=2.29, and on aarch64 with
+  binutils >=2.30.
 
 * Optimized x86-64 asin, atan2, exp, expf, log, pow, atan, sin, cosf,
   sinf, sincosf and tan with FMA, contributed by Arjan van de Ven and
-- 
2.11.0