[v2,2/4] Makefile: Add ld.so.conf with libgcc dir to testroot.pristine

Message ID 20250208160937.3955501-2-dilfridge@gentoo.org (mailing list archive)
State Accepted
Delegated to: Adhemerval Zanella Netto
Headers
Series [v2,1/4] Makeconfig: Add libgcc directory to rtld-prefix search path |

Checks

Context Check Description
redhat-pt-bot/TryBot-apply_patch success Patch applied to master at the time it was sent
linaro-tcwg-bot/tcwg_glibc_build--master-arm success Build passed
linaro-tcwg-bot/tcwg_glibc_build--master-aarch64 success Build passed
linaro-tcwg-bot/tcwg_glibc_check--master-arm success Test passed
linaro-tcwg-bot/tcwg_glibc_check--master-aarch64 success Test passed

Commit Message

Andreas K. Huettel Feb. 8, 2025, 4:09 p.m. UTC
  This way, a nonstandard directory within the testroot containing
libgcc_s.so can actually be picked up and used during the test runs.

Also provide a subdirectory ld.so.conf.d for drop-in configuration

Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
---
 Makefile | 5 +++++
 1 file changed, 5 insertions(+)
  

Comments

Adhemerval Zanella Feb. 25, 2025, 6:46 p.m. UTC | #1
On 08/02/25 13:09, Andreas K. Hüttel wrote:
> This way, a nonstandard directory within the testroot containing
> libgcc_s.so can actually be picked up and used during the test runs.
> 
> Also provide a subdirectory ld.so.conf.d for drop-in configuration
> 
> Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>

LGTM, thanks.

Reviewed-by: Adhemerval Zanella  <adhemerval.zanella@linaro.org>

> ---
>  Makefile | 5 +++++
>  1 file changed, 5 insertions(+)
> 
> diff --git a/Makefile b/Makefile
> index 97b4328af8..cb927fb9f9 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -634,6 +634,11 @@ $(objpfx)testroot.pristine/install.stamp :
>  	cp $(objpfx)support/shell-container $(objpfx)testroot.pristine/bin/sh
>  	cp $(objpfx)support/echo-container $(objpfx)testroot.pristine/bin/echo
>  	cp $(objpfx)support/true-container $(objpfx)testroot.pristine/bin/true
> +	# We need to be able to load extra language libraries.
> +	mkdir -p $(objpfx)testroot.pristine/etc/ld.so.conf.d
> +	echo 'include ld.so.conf.d/*.conf' > $(objpfx)testroot.pristine/etc/ld.so.conf
> +	echo $(gnulib-extralibdir) >> $(objpfx)testroot.pristine/etc/ld.so.conf
> +	echo '# file without content' > $(objpfx)testroot.pristine/etc/ld.so.conf.d/999-empty.conf
>  ifeq ($(run-built-tests),yes)
>  	# Copy these DSOs first so we can overwrite them with our own.
>  	for dso in `$(test-wrapper-env) LD_TRACE_LOADED_OBJECTS=1  \
  

Patch

diff --git a/Makefile b/Makefile
index 97b4328af8..cb927fb9f9 100644
--- a/Makefile
+++ b/Makefile
@@ -634,6 +634,11 @@  $(objpfx)testroot.pristine/install.stamp :
 	cp $(objpfx)support/shell-container $(objpfx)testroot.pristine/bin/sh
 	cp $(objpfx)support/echo-container $(objpfx)testroot.pristine/bin/echo
 	cp $(objpfx)support/true-container $(objpfx)testroot.pristine/bin/true
+	# We need to be able to load extra language libraries.
+	mkdir -p $(objpfx)testroot.pristine/etc/ld.so.conf.d
+	echo 'include ld.so.conf.d/*.conf' > $(objpfx)testroot.pristine/etc/ld.so.conf
+	echo $(gnulib-extralibdir) >> $(objpfx)testroot.pristine/etc/ld.so.conf
+	echo '# file without content' > $(objpfx)testroot.pristine/etc/ld.so.conf.d/999-empty.conf
 ifeq ($(run-built-tests),yes)
 	# Copy these DSOs first so we can overwrite them with our own.
 	for dso in `$(test-wrapper-env) LD_TRACE_LOADED_OBJECTS=1  \