nptl: Make tst-tls3mod.so explicitly lazy

Message ID 20230719192447.2650346-1-arsen@gentoo.org
State Committed
Commit 3edca7f545d226bfbf553e676e22cbfec14adfe8
Headers
Series nptl: Make tst-tls3mod.so explicitly lazy |

Checks

Context Check Description
redhat-pt-bot/TryBot-apply_patch success Patch applied to master at the time it was sent
linaro-tcwg-bot/tcwg_glibc_build--master-arm success Testing passed
redhat-pt-bot/TryBot-32bit success Build for i686
linaro-tcwg-bot/tcwg_glibc_build--master-aarch64 warning Patch failed to apply
linaro-tcwg-bot/tcwg_glibc_check--master-arm warning Patch failed to apply
linaro-tcwg-bot/tcwg_glibc_check--master-aarch64 warning Patch failed to apply

Commit Message

Arsen Arsenović July 19, 2023, 7:24 p.m. UTC
  Fixes the following test-time errors, that lead to FAILs, on toolchains
that set -z now out o the box, such as the one used on Gentoo Hardened:

  .../build-x86-x86_64-pc-linux-gnu-nptl $ grep '' nptl/tst-tls3*.out
  nptl/tst-tls3.out:dlopen failed
  nptl/tst-tls3-malloc.out:dlopen failed
---
Hi,

I've been testing glibc in preparation for 2.38 and spotted two more
test failures caused by a lack of -z lazy, similar to those fixed by
6c7388d0b95ef9ae39fbe6f733e2c5049769c4f9.

This patch fixes those FAILs.

Have a lovely day!

 nptl/Makefile | 1 +
 1 file changed, 1 insertion(+)
  

Comments

Florian Weimer July 20, 2023, 7:23 a.m. UTC | #1
* Arsen Arsenović via Libc-alpha:

> Fixes the following test-time errors, that lead to FAILs, on toolchains
> that set -z now out o the box, such as the one used on Gentoo Hardened:
>
>   .../build-x86-x86_64-pc-linux-gnu-nptl $ grep '' nptl/tst-tls3*.out
>   nptl/tst-tls3.out:dlopen failed
>   nptl/tst-tls3-malloc.out:dlopen failed
> ---
> Hi,
>
> I've been testing glibc in preparation for 2.38 and spotted two more
> test failures caused by a lack of -z lazy, similar to those fixed by
> 6c7388d0b95ef9ae39fbe6f733e2c5049769c4f9.
>
> This patch fixes those FAILs.
>
> Have a lovely day!
>
>  nptl/Makefile | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/nptl/Makefile b/nptl/Makefile
> index f8365467d9..ffa5722e48 100644
> --- a/nptl/Makefile
> +++ b/nptl/Makefile
> @@ -636,6 +636,7 @@ $(objpfx)tst-cleanup4: $(objpfx)tst-cleanup4aux.o
>  $(objpfx)tst-cleanupx4: $(objpfx)tst-cleanupx4aux.o
>  
>  LDFLAGS-tst-tls3 = -rdynamic
> +LDFLAGS-tst-tls3mod.so = -Wl,-z,lazy
>  $(objpfx)tst-tls3.out: $(objpfx)tst-tls3mod.so
>  
>  LDFLAGS-tst-tls3-malloc = -rdynamic

Looks reasonable.  Can you apply this yourself?

Reviewed-by: Florian Weimer <fweimer@redhat.com>

Thanks,
Florian
  
Arsen Arsenović July 20, 2023, 8:04 a.m. UTC | #2
Florian Weimer <fweimer@redhat.com> writes:

> * Arsen Arsenović via Libc-alpha:
> [...snip...]
>
> Looks reasonable.  Can you apply this yourself?
>
> Reviewed-by: Florian Weimer <fweimer@redhat.com>
>
> Thanks,
> Florian

No, I do not have write rights currently.

Thanks for the review, have a lovely day.
  
Andreas K. Huettel July 20, 2023, 10:25 a.m. UTC | #3
Am Donnerstag, 20. Juli 2023, 10:04:01 CEST schrieb Arsen Arsenović via Libc-alpha:
> 
> Florian Weimer <fweimer@redhat.com> writes:
> 
> > * Arsen Arsenović via Libc-alpha:
> > [...snip...]
> >
> > Looks reasonable.  Can you apply this yourself?
> >
> > Reviewed-by: Florian Weimer <fweimer@redhat.com>
> >
> > Thanks,
> > Florian
> 
> No, I do not have write rights currently.
> 
> Thanks for the review, have a lovely day.
> 

Pushed, thanks!
  

Patch

diff --git a/nptl/Makefile b/nptl/Makefile
index f8365467d9..ffa5722e48 100644
--- a/nptl/Makefile
+++ b/nptl/Makefile
@@ -636,6 +636,7 @@  $(objpfx)tst-cleanup4: $(objpfx)tst-cleanup4aux.o
 $(objpfx)tst-cleanupx4: $(objpfx)tst-cleanupx4aux.o
 
 LDFLAGS-tst-tls3 = -rdynamic
+LDFLAGS-tst-tls3mod.so = -Wl,-z,lazy
 $(objpfx)tst-tls3.out: $(objpfx)tst-tls3mod.so
 
 LDFLAGS-tst-tls3-malloc = -rdynamic