[v3,2/2] elf: Add missing dependency between resolvfail and testobj1.so

Message ID 20230307102935.2882450-2-arsen@gentoo.org
State Committed
Commit f7e751affbedf67e16ef97e9da430bd67d793891
Headers
Series [v3,1/2] elf,nptl: Add -z lazy to some more tests |

Checks

Context Check Description
dj/TryBot-apply_patch success Patch applied to master at the time it was sent
dj/TryBot-32bit success Build for i686

Commit Message

Arsen Arsenović March 7, 2023, 10:29 a.m. UTC
  It was possible to run this test individually and have it fail because
it can't find testobj1.so.  This patch adds that dependency, to prevent
such issues.
---
 elf/Makefile | 1 +
 1 file changed, 1 insertion(+)
  

Patch

diff --git a/elf/Makefile b/elf/Makefile
index b9c77604b5..a32618a01f 100644
--- a/elf/Makefile
+++ b/elf/Makefile
@@ -1615,6 +1615,7 @@  $(objpfx)multiload.out: $(objpfx)testobj1.so
 LDFLAGS-origtest = -rdynamic
 $(objpfx)origtest.out: $(objpfx)testobj1.so
 
+$(objpfx)resolvfail.out: $(objpfx)testobj1.so
 ifeq ($(have-thread-library),yes)
 $(objpfx)resolvfail: $(shared-thread-library)
 endif