[0/3] More getaddrinfo refactoring

Message ID 20220314173039.1060650-1-siddhesh@sourceware.org


Siddhesh Poyarekar March 14, 2022, 5:30 p.m. UTC
  These are refactoring patches in parts of getaddrinfo implementation other than
gaih_inet, aimed at improving readability of the code.

Tested with x86_64 and i686 build and check.

Siddhesh Poyarekar (3):
  gaiconf_init: Refactor some bits for readability
  gai_init: Avoid jumping from if condition to its else counterpart
  getaddrinfo: Refactor code for readability

 sysdeps/posix/getaddrinfo.c | 651 +++++++++++++++++++-----------------
 1 file changed, 345 insertions(+), 306 deletions(-)