manual: skip build when perl is unavailable
Commit Message
Do not try to generate the manual when perl is unavailable. This
matches the behavior when makeinfo is unavailable. Otherwise the
install step fails when trying to generate the libm section since
it runs a perl script.
2015-08-21 Mike Frysinger <vapier@gentoo.org>
* manual/Makefile (install): Only build manual when perl is available.
---
manual/Makefile | 2 ++
1 file changed, 2 insertions(+)
Comments
On Fri, 21 Aug 2015, Mike Frysinger wrote:
> Do not try to generate the manual when perl is unavailable. This
> matches the behavior when makeinfo is unavailable. Otherwise the
> install step fails when trying to generate the libm section since
> it runs a perl script.
OK with a comment on the ifneq saying "libm-err.texi generation requires
perl" or similar.
On 08/21/2015 07:17 PM, Mike Frysinger wrote:
> Do not try to generate the manual when perl is unavailable. This
> matches the behavior when makeinfo is unavailable. Otherwise the
> install step fails when trying to generate the libm section since
> it runs a perl script.
Isn't this redundant with the makeinfo check because makeinfo is written
in Perl?
On Fri, Aug 21, 2015 at 08:50:29PM +0200, Florian Weimer wrote:
> On 08/21/2015 07:17 PM, Mike Frysinger wrote:
> > Do not try to generate the manual when perl is unavailable. This
> > matches the behavior when makeinfo is unavailable. Otherwise the
> > install step fails when trying to generate the libm section since
> > it runs a perl script.
>
> Isn't this redundant with the makeinfo check because makeinfo is written
> in Perl?
Not so long ago makeinfo used to be an ELF executable.
On 21 Aug 2015 21:58, Dmitry V. Levin wrote:
> On Fri, Aug 21, 2015 at 08:50:29PM +0200, Florian Weimer wrote:
> > On 08/21/2015 07:17 PM, Mike Frysinger wrote:
> > > Do not try to generate the manual when perl is unavailable. This
> > > matches the behavior when makeinfo is unavailable. Otherwise the
> > > install step fails when trying to generate the libm section since
> > > it runs a perl script.
> >
> > Isn't this redundant with the makeinfo check because makeinfo is written
> > in Perl?
>
> Not so long ago makeinfo used to be an ELF executable.
right -- the perl rewrite is new to the latest versions (5.0+), and the
configure script doesn't require those. so an alternative would be to
stop accepting makeinfo 4.x.
-mike
Mike Frysinger <vapier@gentoo.org> writes:
> On 21 Aug 2015 21:58, Dmitry V. Levin wrote:
>> On Fri, Aug 21, 2015 at 08:50:29PM +0200, Florian Weimer wrote:
>> > On 08/21/2015 07:17 PM, Mike Frysinger wrote:
>> > > Do not try to generate the manual when perl is unavailable. This
>> > > matches the behavior when makeinfo is unavailable. Otherwise the
>> > > install step fails when trying to generate the libm section since
>> > > it runs a perl script.
>> >
>> > Isn't this redundant with the makeinfo check because makeinfo is written
>> > in Perl?
>>
>> Not so long ago makeinfo used to be an ELF executable.
>
> right -- the perl rewrite is new to the latest versions (5.0+), and the
> configure script doesn't require those. so an alternative would be to
> stop accepting makeinfo 4.x.
Until makeinfo is rewritten again...
Andreas.
On 21 Aug 2015 17:20, Joseph Myers wrote:
> On Fri, 21 Aug 2015, Mike Frysinger wrote:
> > Do not try to generate the manual when perl is unavailable. This
> > matches the behavior when makeinfo is unavailable. Otherwise the
> > install step fails when trying to generate the libm section since
> > it runs a perl script.
>
> OK with a comment on the ifneq saying "libm-err.texi generation requires
> perl" or similar.
donesky
-mike
@@ -172,6 +172,7 @@ include ../Rules
.PHONY: install subdir_install install-data
install-data subdir_install: install
+ifneq ($(PERL),no)
ifneq ($(strip $(MAKEINFO)),:)
install: $(inst_infodir)/libc.info
@if $(SHELL) -c '$(INSTALL_INFO) --version' >/dev/null 2>&1; then \
@@ -179,6 +180,7 @@ install: $(inst_infodir)/libc.info
$(INSTALL_INFO) --info-dir=$(inst_infodir) $(inst_infodir)/libc.info;\
else : ; fi
endif
+endif
# Catchall implicit rule for other installation targets from the parent.
install-%: ;