[2/4] gdb/testsuite: Rename skip_hipcc_tests to allow_hipcc_tests
Commit Message
Rename skip_hipcc_tests to allow_hipcc_tests so it can be used as a
"require" predicate in tests.
Use require in gdb.rocm/simple.exp.
---
gdb/testsuite/gdb.rocm/simple.exp | 5 +----
gdb/testsuite/lib/rocm.exp | 6 +++---
2 files changed, 4 insertions(+), 7 deletions(-)
@@ -20,10 +20,7 @@ load_lib rocm.exp
standard_testfile .cpp
-if [skip_hipcc_tests] {
- verbose "skipping hip test: ${testfile}"
- return
-}
+require allow_hipcc_tests
if {[build_executable "failed to prepare" $testfile $srcfile {debug hip}]} {
return
@@ -15,14 +15,14 @@
#
# Support library for testing ROCm (AMD GPU) GDB features.
-proc skip_hipcc_tests { } {
+proc allow_hipcc_tests { } {
# Only the native target supports ROCm debugging. E.g., when
# testing against GDBserver, there's no point in running the ROCm
# tests.
if {[target_info gdb_protocol] != ""} {
- return 1
+ return 0
}
- return 0
+ return 1
}
# The lock file used to ensure that only one GDB has access to the GPU