[3/3] Don't let gdb_stdlog use pager
Commit Message
When using the "set logging" commands, cli_interp_base::set_logging
will send gdb_stdlog output (among others) to the tee it makes for
gdb_stdout. However, this has the side effect of also causing logging
to use the pager. This is PR gdb/29787.
This patch fixes the problem by keeping stderr and stdlog separate
from stdout, preserving the rule that only gdb_stdout should page.
Bug: https://sourceware.org/bugzilla/show_bug.cgi?id=29787
---
gdb/cli/cli-interp.c | 24 ++++++++++++++----------
gdb/cli/cli-interp.h | 1 +
2 files changed, 15 insertions(+), 10 deletions(-)
Comments
> diff --git a/gdb/cli/cli-interp.h b/gdb/cli/cli-interp.h
> index fa007d78621..978e7f291e4 100644
> --- a/gdb/cli/cli-interp.h
> +++ b/gdb/cli/cli-interp.h
> @@ -42,6 +42,7 @@ class cli_interp_base : public interp
> ui_file *targ;
> ui_file *targerr;
> ui_file_up tee_to_delete;
> + ui_file_up stderr_to_delete;
> ui_file_up file_to_delete;
> ui_file_up log_to_delete;
I think it would help me understand if the naming of these fields was a
bit better. I think the to_delete suffixes are no longer relevant
since using ui_file_up, the types tell us about the ownership. And I
think that "tee_to_delete" could be named "stdout_tee", and
"stderr_to_delete" could be named "stderr_tee".
Not terribly important, perhaps as a follow up.
Simon
>>>>> "Simon" == Simon Marchi via Gdb-patches <gdb-patches@sourceware.org> writes:
>> diff --git a/gdb/cli/cli-interp.h b/gdb/cli/cli-interp.h
>> index fa007d78621..978e7f291e4 100644
>> --- a/gdb/cli/cli-interp.h
>> +++ b/gdb/cli/cli-interp.h
>> @@ -42,6 +42,7 @@ class cli_interp_base : public interp
>> ui_file *targ;
>> ui_file *targerr;
>> ui_file_up tee_to_delete;
>> + ui_file_up stderr_to_delete;
>> ui_file_up file_to_delete;
>> ui_file_up log_to_delete;
Simon> I think it would help me understand if the naming of these fields was a
Simon> bit better. I think the to_delete suffixes are no longer relevant
Simon> since using ui_file_up, the types tell us about the ownership. And I
Simon> think that "tee_to_delete" could be named "stdout_tee", and
Simon> "stderr_to_delete" could be named "stderr_tee".
Simon> Not terribly important, perhaps as a follow up.
I'll send a follow-up for this as well.
Tom
@@ -389,24 +389,28 @@ cli_interp_base::set_logging (ui_file_up logfile, bool logging_redirect,
ui_file *logfile_p = logfile.get ();
m_saved_output->file_to_delete = std::move (logfile);
- /* If something is not being redirected, then a tee containing both the
- logfile and stdout. */
- ui_file *tee = nullptr;
- if (!logging_redirect || !debug_redirect)
+ /* The new stdout and stderr only depend on whether logging
+ redirection is being done. */
+ ui_file *new_stdout = logfile_p;
+ ui_file *new_stderr = logfile_p;
+ if (!logging_redirect)
{
m_saved_output->tee_to_delete.reset
(new tee_file (gdb_stdout, logfile_p));
- tee = m_saved_output->tee_to_delete.get ();
+ new_stdout = m_saved_output->tee_to_delete.get ();
+ m_saved_output->stderr_to_delete.reset
+ (new tee_file (gdb_stderr, logfile_p));
+ new_stderr = m_saved_output->stderr_to_delete.get ();
}
m_saved_output->log_to_delete.reset
- (new timestamped_file (debug_redirect ? logfile_p : tee));
+ (new timestamped_file (debug_redirect ? logfile_p : new_stderr));
- gdb_stdout = logging_redirect ? logfile_p : tee;
+ gdb_stdout = new_stdout;
gdb_stdlog = m_saved_output->log_to_delete.get ();
- gdb_stderr = logging_redirect ? logfile_p : tee;
- gdb_stdtarg = logging_redirect ? logfile_p : tee;
- gdb_stdtargerr = logging_redirect ? logfile_p : tee;
+ gdb_stderr = new_stderr;
+ gdb_stdtarg = new_stderr;
+ gdb_stdtargerr = new_stderr;
}
else
{
@@ -42,6 +42,7 @@ class cli_interp_base : public interp
ui_file *targ;
ui_file *targerr;
ui_file_up tee_to_delete;
+ ui_file_up stderr_to_delete;
ui_file_up file_to_delete;
ui_file_up log_to_delete;
};