sim: ppc: rename ppc-instructions to powerpc.igen

Message ID 20221110085457.12812-1-vapier@gentoo.org
State Committed
Commit 689c2b4b65fb5d0ce6b6414685e1f5c6f97d7c25
Headers
Series sim: ppc: rename ppc-instructions to powerpc.igen |

Commit Message

Mike Frysinger Nov. 10, 2022, 8:54 a.m. UTC
  To make it clear this is an input to the igen tool, rename it with an
igen extension.  This matches the other files in the ppc dir (altivec
& e500 igen files), and the other igen ports (mips, mn10300, v850).
---
 sim/ppc/BUGS                               | 2 +-
 sim/ppc/INSTALL                            | 6 +++---
 sim/ppc/Makefile.in                        | 4 ++--
 sim/ppc/{ppc-instructions => powerpc.igen} | 0
 4 files changed, 6 insertions(+), 6 deletions(-)
 rename sim/ppc/{ppc-instructions => powerpc.igen} (100%)
  

Patch

diff --git a/sim/ppc/BUGS b/sim/ppc/BUGS
index 362b079e90c9..300c79120ce5 100644
--- a/sim/ppc/BUGS
+++ b/sim/ppc/BUGS
@@ -15,7 +15,7 @@  VEA:
 
 Missing VEA system calls.
 
-ppc-instructions:
+powerpc.igen:
 
 Missing or commented out instructions.
 
diff --git a/sim/ppc/INSTALL b/sim/ppc/INSTALL
index 9feac7b9e61f..22ead08de5f6 100644
--- a/sim/ppc/INSTALL
+++ b/sim/ppc/INSTALL
@@ -218,7 +218,7 @@  With just --enable-sim-warnings, the following -W options are enabled:
 
 
 Specify the file containing the rules for generating the instruction
-decode and execute functions from the file ppc-instructions.
+decode and execute functions from the file powerpc.igen.
 
 The form of the instruction decode and execute functions is controlled
 by an opcode table.  It specifies: the combination of switch
@@ -303,7 +303,7 @@  Create a duplicate copy of each instruction function hardwiring
 instruction fields that would have otherwise have been variable.
 
 As discussed above, igen outputs a C function generated from the file
-ppc-instructions (using the opcode rules) for each of the
+powerpc.igen (using the opcode rules) for each of the
 instructions.  Thus multiple entries in the instruction decode tables
 may be pointing back at the same function.  Enabling duplicate, will
 result in psim creating a duplicate of the instruction's function for
@@ -343,7 +343,7 @@  disabled (using: --disable-sim-duplicate).
 Include/exclude PowerPC instructions that are specific to a particular
 implementation.
 
-Some of the PowerPC instructions included in the file ppc-instructions
+Some of the PowerPC instructions included in the file powerpc.igen
 are limited to certain specific PPC implementations.  For instance,
 the instruction:
 
diff --git a/sim/ppc/Makefile.in b/sim/ppc/Makefile.in
index 05f357a31a0a..54e755e5bfeb 100644
--- a/sim/ppc/Makefile.in
+++ b/sim/ppc/Makefile.in
@@ -607,10 +607,10 @@  tmp-dgen: dgen ppc-spr-table $(srcroot)/move-if-change
 	$(SILENCE) $(SHELL) $(srcroot)/move-if-change tmp-spreg.c spreg.c
 	$(SILENCE) touch $@
 
-tmp-igen: igen $(srcdir)/ppc-instructions $(srcdir)/altivec.igen $(srcdir)/e500.igen $(IGEN_OPCODE_RULES) $(srcroot)/move-if-change
+tmp-igen: igen $(srcdir)/powerpc.igen $(srcdir)/altivec.igen $(srcdir)/e500.igen $(IGEN_OPCODE_RULES) $(srcroot)/move-if-change
 	$(ECHO_GEN) $(IGEN) $(IGEN_FLAGS) \
 		-o $(srcdir)/$(IGEN_OPCODE_RULES) \
-		-I $(srcdir) -i $(srcdir)/ppc-instructions \
+		-I $(srcdir) -i $(srcdir)/powerpc.igen \
 		-n icache.h    -hc tmp-icache.h \
 		-n icache.c    -c  tmp-icache.c \
 		-n semantics.h -hs tmp-semantics.h \
diff --git a/sim/ppc/ppc-instructions b/sim/ppc/powerpc.igen
similarity index 100%
rename from sim/ppc/ppc-instructions
rename to sim/ppc/powerpc.igen