sim: .gdbinit: generate for all arch subdirs

Message ID 20221107145303.24858-1-vapier@gentoo.org
State Committed
Headers
Series sim: .gdbinit: generate for all arch subdirs |

Commit Message

Mike Frysinger Nov. 7, 2022, 2:53 p.m. UTC
  This was being skipped for ports that had a recursive configure,
but we want it for them too.
---
 sim/Makefile.in  | 100 ++++++++++++---------
 sim/configure    | 221 ++++++++++++++++++++++++++---------------------
 sim/configure.ac |   2 +-
 3 files changed, 180 insertions(+), 143 deletions(-)
  

Patch

diff --git a/sim/configure.ac b/sim/configure.ac
index 3c3743779229..8bde2a49fdfc 100644
--- a/sim/configure.ac
+++ b/sim/configure.ac
@@ -71,7 +71,6 @@  m4_define([SIM_BUILD_TARGET], [dnl
   m4_if($2, [true], [dnl
     AC_CONFIG_SUBDIRS($1)
   ], [dnl
-    AC_CONFIG_FILES($1/.gdbinit:common/gdbinit.in)
     AC_CONFIG_FILES($1/Makefile.sim:$1/Makefile.in)
     AC_CONFIG_COMMANDS([$1/Makefile],
 [sed -n \
@@ -88,6 +87,7 @@  m4_define([SIM_BUILD_TARGET], [dnl
 ])
     AS_VAR_APPEND([SIM_SUBDIRS], [" $1"])
   ])
+  AC_CONFIG_FILES($1/.gdbinit:common/gdbinit.in)
   dnl Create the depdirs for ports until we can convert them to automake.
   AC_CONFIG_COMMANDS([depdir-$1],
 		     [$SHELL $ac_aux_dir/mkinstalldirs $1/$DEPDIR],