sim: build: respect AM_MAKEFLAGS when entering subdirs

Message ID 20221106144924.27341-1-vapier@gentoo.org
State Committed
Headers
Series sim: build: respect AM_MAKEFLAGS when entering subdirs |

Commit Message

Mike Frysinger Nov. 6, 2022, 2:49 p.m. UTC
  This doesn't matter right now, but it will as we add more flags to
the recursive make step to pass state down.
---
 sim/Makefile.am    |  4 ++--
 sim/Makefile.in    | 14 +++++++-------
 sim/erc32/local.mk |  2 +-
 sim/m32c/local.mk  |  2 +-
 sim/ppc/local.mk   |  2 +-
 sim/rl78/local.mk  |  2 +-
 sim/rx/local.mk    |  2 +-
 7 files changed, 14 insertions(+), 14 deletions(-)
  

Patch

diff --git a/sim/Makefile.am b/sim/Makefile.am
index b8d592ade4d2..7cdcc6013077 100644
--- a/sim/Makefile.am
+++ b/sim/Makefile.am
@@ -188,10 +188,10 @@  endif
 ## have Makefiles in subdirs.
 
 %/libsim.a: | $(SIM_ALL_RECURSIVE_DEPS)
-	$(MAKE) -C $(@D) $(@F)
+	$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
 
 %/nrun.o: common/nrun.c | %/libsim.a $(SIM_ALL_RECURSIVE_DEPS)
-	$(MAKE) -C $(@D) $(@F)
+	$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
 
 all-recursive: $(SIM_ALL_RECURSIVE_DEPS)
 
diff --git a/sim/erc32/local.mk b/sim/erc32/local.mk
index 1c6f7b3dbbd9..b53bcf8f6ca6 100644
--- a/sim/erc32/local.mk
+++ b/sim/erc32/local.mk
@@ -28,7 +28,7 @@ 
 
 ## Helper targets for running make from the top-level due to run's sis.o.
 %D%/%.o: %D%/%.c | %D%/libsim.a $(SIM_ALL_RECURSIVE_DEPS)
-	$(MAKE) -C $(@D) $(@F)
+	$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
 
 noinst_PROGRAMS += %D%/run %D%/sis
 
diff --git a/sim/m32c/local.mk b/sim/m32c/local.mk
index efdf110e6309..d38d555367eb 100644
--- a/sim/m32c/local.mk
+++ b/sim/m32c/local.mk
@@ -26,7 +26,7 @@  noinst_PROGRAMS += %D%/run
 
 ## Helper targets for running make from the top-level due to run's main.o.
 %D%/%.o: %D%/%.c | %D%/libsim.a $(SIM_ALL_RECURSIVE_DEPS)
-	$(MAKE) -C $(@D) $(@F)
+	$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
 
 %C%_BUILD_OUTPUTS = \
 	%D%/opc2c$(EXEEXT) \
diff --git a/sim/ppc/local.mk b/sim/ppc/local.mk
index 19a8a89ba47c..37d67b0adba0 100644
--- a/sim/ppc/local.mk
+++ b/sim/ppc/local.mk
@@ -26,7 +26,7 @@ 
 
 ## Helper targets for running make from the top-level due to run's sis.o.
 %D%/%.o: %D%/%.c | %D%/libsim.a $(SIM_ALL_RECURSIVE_DEPS)
-	$(MAKE) -C $(@D) $(@F)
+	$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
 
 noinst_PROGRAMS += %D%/run %D%/psim
 
diff --git a/sim/rl78/local.mk b/sim/rl78/local.mk
index 132fa3abccbd..d38d4aa76c7c 100644
--- a/sim/rl78/local.mk
+++ b/sim/rl78/local.mk
@@ -26,4 +26,4 @@  noinst_PROGRAMS += %D%/run
 
 ## Helper targets for running make from the top-level due to run's main.o.
 %D%/%.o: %D%/%.c | %D%/libsim.a $(SIM_ALL_RECURSIVE_DEPS)
-	$(MAKE) -C $(@D) $(@F)
+	$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
diff --git a/sim/rx/local.mk b/sim/rx/local.mk
index 119a0f7ccf8d..e26ea82f2fdd 100644
--- a/sim/rx/local.mk
+++ b/sim/rx/local.mk
@@ -26,7 +26,7 @@  noinst_PROGRAMS += %D%/run
 
 ## Helper targets for running make from the top-level due to run's main.o.
 %D%/%.o: %D%/%.c | %D%/libsim.a $(SIM_ALL_RECURSIVE_DEPS)
-	$(MAKE) -C $(@D) $(@F)
+	$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
 
 %C%docdir = $(docdir)/%C%
 %C%doc_DATA = %D%/README.txt