sim: fix readline linkage

Message ID 20221105142302.10881-1-vapier@gentoo.org
State Committed
Headers
Series sim: fix readline linkage |

Commit Message

Mike Frysinger Nov. 5, 2022, 2:23 p.m. UTC
  Now that we link programs in the top dir instead of the arch subdir,
update the readline library path to be relative to the top dir.
---
 sim/configure             | 2 +-
 sim/m4/sim_ac_platform.m4 | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
  

Patch

diff --git a/sim/m4/sim_ac_platform.m4 b/sim/m4/sim_ac_platform.m4
index 467987e11e7e..abfb2bd9e6e6 100644
--- a/sim/m4/sim_ac_platform.m4
+++ b/sim/m4/sim_ac_platform.m4
@@ -190,7 +190,7 @@  AC_SUBST(TERMCAP_LIB)
 dnl We prefer the in-tree readline.  Top-level dependencies make sure
 dnl src/readline (if it's there) is configured before src/sim.
 if test -r ../readline/Makefile; then
-  READLINE_LIB=../../readline/readline/libreadline.a
+  READLINE_LIB=../readline/readline/libreadline.a
   READLINE_CFLAGS='-I$(READLINE_SRC)/..'
 else
   AC_CHECK_LIB(readline, readline, READLINE_LIB=-lreadline,