sim: cris: move rvdummy linking to top-level

Message ID 20221105042249.22511-1-vapier@gentoo.org
State Committed
Headers
Series sim: cris: move rvdummy linking to top-level |

Commit Message

Mike Frysinger Nov. 5, 2022, 4:22 a.m. UTC
  This is only used by `make check`, so we can move it out of the
default build too.
---
 sim/Makefile.in      | 113 ++++++++++++++++++++++++++-----------------
 sim/cris/Makefile.in |  13 +----
 sim/cris/local.mk    |   7 +++
 3 files changed, 77 insertions(+), 56 deletions(-)
  

Patch

diff --git a/sim/cris/Makefile.in b/sim/cris/Makefile.in
index 7b69c114d929..3474eb9a827b 100644
--- a/sim/cris/Makefile.in
+++ b/sim/cris/Makefile.in
@@ -39,20 +39,9 @@  SIM_EXTRA_CLEAN = cris-clean
 
 arch = cris
 
-# rvdummy is just used for testing.  It does nothing if
-# --enable-sim-hardware isn't active.
-
-all: rvdummy$(EXEEXT)
-
-check: rvdummy$(EXEEXT)
-
-rvdummy$(EXEEXT): rvdummy.o $(EXTRA_LIBDEPS)
-	$(ECHO_CCLD) $(LIBTOOL) $(AM_V_lt) --tag=CC --mode=link \
-	  $(CC) $(ALL_CFLAGS) -o rvdummy$(EXEEXT) rvdummy.o $(EXTRA_LIBS)
-
 cris-clean:
 	-rm -f stamp-arch
-	-rm -f tmp-* rvdummy$(EXEEXT)
+	-rm -f tmp-*
 
 # Useful when making CGEN-generated files manually, without --enable-cgen-maint.
 stamps: stamp-arch stamp-v10fcpu stamp-v32fcpu
diff --git a/sim/cris/local.mk b/sim/cris/local.mk
index 9416b7e8c014..62a3f8e80abf 100644
--- a/sim/cris/local.mk
+++ b/sim/cris/local.mk
@@ -16,6 +16,13 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
+## rvdummy is just used for testing -- it runs on the same host as `run`.
+## It does nothing if --enable-sim-hardware isn't active.
+%C%_rvdummy_SOURCES = %D%/rvdummy.c
+%C%_rvdummy_LDADD = $(LIBIBERTY_LIB)
+
+check_PROGRAMS += %D%/rvdummy
+
 %C%_BUILD_OUTPUTS = \
 	%D%/engv10.h \
 	%D%/mloopv10f.c \