sim: ppc: drop unused /dev/zero logic

Message ID 20221105035623.17239-1-vapier@gentoo.org
State Committed
Headers
Series sim: ppc: drop unused /dev/zero logic |

Commit Message

Mike Frysinger Nov. 5, 2022, 3:56 a.m. UTC
  Nothing in the tree checks this option, or has checked for decades.
The pre-cvs-import ChangeLog suggests this was added & removed back
then, but can't be sure as that history doesn't exist in the VCS.
---
 sim/ppc/Makefile.in  |  4 +---
 sim/ppc/configure    | 49 --------------------------------------------
 sim/ppc/configure.ac | 28 -------------------------
 sim/ppc/options.c    |  4 ----
 4 files changed, 1 insertion(+), 84 deletions(-)
  

Patch

diff --git a/sim/ppc/Makefile.in b/sim/ppc/Makefile.in
index 6575f962c9dd..72dc479d1912 100644
--- a/sim/ppc/Makefile.in
+++ b/sim/ppc/Makefile.in
@@ -74,7 +74,6 @@  FLOAT_CFLAGS = @sim_float@
 MONITOR_CFLAGS = @sim_monitor@
 MODEL_CFLAGS = @sim_model@ @sim_default_model@ @sim_model_issue@
 TERMIO_CFLAGS = @sim_termio@
-DEVZERO_CFLAGS = @sim_devzero@
 CONFIG_CFLAGS = \
   $(SMP_CFLAGS) \
   $(XOR_ENDIAN_CFLAGS) \
@@ -84,8 +83,7 @@  CONFIG_CFLAGS = \
   $(FLOAT_CFLAGS) \
   $(MONITOR_CFLAGS) \
   $(MODEL_CFLAGS) \
-  $(TERMIO_CFLAGS) \
-  $(DEVZERO_CFLAGS)
+  $(TERMIO_CFLAGS)
 SIM_FPU_CFLAGS = -DHAVE_COMMON_FPU -I../common -I${srcdir}/../common
 
 STD_CFLAGS	= $(CFLAGS) $(WERROR_CFLAGS) $(INLINE_CFLAGS) $(CONFIG_CFLAGS) $(WARN_CFLAGS) $(INCLUDES) $(INCGNU) $(SIM_FPU_CFLAGS)
diff --git a/sim/ppc/configure.ac b/sim/ppc/configure.ac
index 3054202dea20..542e8a105fbb 100644
--- a/sim/ppc/configure.ac
+++ b/sim/ppc/configure.ac
@@ -490,33 +490,6 @@  fi
 
 AC_CHECK_TYPES(long long)
 
-dnl Figure out if /dev/zero exists or not
-sim_devzero=""
-AC_MSG_CHECKING(for /dev/zero)
-AC_CACHE_VAL(ac_cv_devzero,
-[AC_TRY_RUN([#include <fcntl.h>
-main () {
-  char buf[2048];
-  int i;
-  int fd = open ("/dev/zero", O_RDONLY);
-  if (fd < 0)
-    return 1;
-  for (i = 0; i < sizeof (buf); i++)
-    buf[i] = 1;
-  if (read (fd, buf, sizeof (buf)) != sizeof (buf))
-    return 1;
-  for (i = 0; i < sizeof (buf); i++)
-    if (buf[i])
-      return 1;
-  return 0;
-}],[ac_cv_devzero=yes],[ac_cv_devzero=no],[ac_cv_devzero=no])])
-AC_MSG_RESULT($ac_cv_devzero)
-if test $ac_cv_devzero = yes; then
-  sim_devzero="-DHAVE_DEVZERO"
-else
-  sim_devzero=""
-fi
-
 # Since we run commands on the build system, we have to create a
 # separate config header for the build system if build != host.
 if test x$host = x$build; then
@@ -570,7 +543,6 @@  AC_SUBST(sim_model)
 AC_SUBST(sim_default_model)
 AC_SUBST(sim_model_issue)
 AC_SUBST(sim_termio)
-AC_SUBST(sim_devzero)
 
 AC_OUTPUT(Makefile,
 [case x$CONFIG_HEADERS in xconfig.h:config.in) echo > stamp-h ;; esac])
diff --git a/sim/ppc/options.c b/sim/ppc/options.c
index 8e1c2629940a..a696db1b623e 100644
--- a/sim/ppc/options.c
+++ b/sim/ppc/options.c
@@ -198,10 +198,6 @@  print_options (void)
 #ifdef HAVE_TERMIO_STRUCTURE
       "HAVE_TERMIO_STRUCTURE",
 #endif
-
-#ifdef HAVE_DEVZERO
-      "HAVE_DEVZERO",
-#endif
     };
 
     int i;