[3/3] sim: build: add SIM_HW_CFLAGS to top-level build too

Message ID 20221105035047.11654-3-vapier@gentoo.org
State Committed
Headers
Series [1/3] sim: adjust sim_hw options style |

Commit Message

Mike Frysinger Nov. 5, 2022, 3:50 a.m. UTC
  This matches what we do with targets already.
---
 sim/Makefile.am | 2 ++
 sim/Makefile.in | 7 ++++---
 2 files changed, 6 insertions(+), 3 deletions(-)
  

Patch

diff --git a/sim/Makefile.am b/sim/Makefile.am
index d8730f276988..7ea013ac1965 100644
--- a/sim/Makefile.am
+++ b/sim/Makefile.am
@@ -46,10 +46,12 @@  AM_CPPFLAGS = \
 	-I$(srcroot)/include \
 	-I../bfd \
 	-I.. \
+	$(SIM_HW_CFLAGS) \
 	$(SIM_INLINE)
 
 AM_CPPFLAGS_FOR_BUILD = \
 	-I$(srcroot)/include \
+	$(SIM_HW_CFLAGS) \
 	$(SIM_INLINE)
 COMPILE_FOR_BUILD = $(CC_FOR_BUILD) $(AM_CPPFLAGS_FOR_BUILD) $(CPPFLAGS_FOR_BUILD) $(CFLAGS_FOR_BUILD)
 LINK_FOR_BUILD = $(CC_FOR_BUILD) $(CFLAGS_FOR_BUILD) $(LDFLAGS_FOR_BUILD) -o $@