sim: v850: switch to standard (high-level) trace defines

Message ID 20221103154712.19404-1-vapier@gentoo.org
State Committed
Commit b830591caf0db7bb416f0be3145b00db6ba1ea4c
Headers
Series sim: v850: switch to standard (high-level) trace defines |

Commit Message

Mike Frysinger Nov. 3, 2022, 3:47 p.m. UTC
  The v850 port uses -DDEBUG to control whether to enable internal tracing.
We already have such options via the common trace framework, and those
can be controlled at build time via configure flags (which the v850 code
currently cannot).  So switch it over to WITH_TRACE_ANY_P to simplify the
v850 build code even if it doesn't (yet) respect any other trace options.
---
 sim/v850/Makefile.in | 4 ----
 sim/v850/sim-main.h  | 2 +-
 sim/v850/simops.c    | 2 +-
 3 files changed, 2 insertions(+), 6 deletions(-)
  

Patch

diff --git a/sim/v850/Makefile.in b/sim/v850/Makefile.in
index 4c2d278d0a59..ab4214526a4c 100644
--- a/sim/v850/Makefile.in
+++ b/sim/v850/Makefile.in
@@ -27,8 +27,4 @@  SIM_OBJS = \
 # Generally this consists of simulator specific files included by sim-main.h.
 SIM_EXTRA_DEPS = v850_sim.h sim-main.h
 
-# List of flags to always pass to $(CC)
-SIM_EXTRA_CFLAGS = \
-	-DDEBUG
-
 ## COMMON_POST_CONFIG_FRAG
diff --git a/sim/v850/sim-main.h b/sim/v850/sim-main.h
index 49b845dfe7ae..ab7e47aa240a 100644
--- a/sim/v850/sim-main.h
+++ b/sim/v850/sim-main.h
@@ -435,7 +435,7 @@  enum op_types
   OP_PUSHPOP3,
 };
 
-#ifdef DEBUG
+#if WITH_TRACE_ANY_P
 void trace_input (char *name, enum op_types type, int size);
 void trace_output (enum op_types result);
 void trace_result (int has_result, uint32_t result);
diff --git a/sim/v850/simops.c b/sim/v850/simops.c
index 573ece54ec71..1d5403be561c 100644
--- a/sim/v850/simops.c
+++ b/sim/v850/simops.c
@@ -39,7 +39,7 @@  int type2_regs[16] = { 3, 2, 1, 0, 27, 26, 25, 24, 31, 30, 29, 28, 23, 22, 20, 2
    that order in a push/pop instruction.  */
 int type3_regs[15] = { 2, 1, 0, 27, 26, 25, 24, 31, 30, 29, 28, 23, 22, 20, 21};
 
-#ifdef DEBUG
+#if WITH_TRACE_ANY_P
 #ifndef SIZE_INSTRUCTION
 #define SIZE_INSTRUCTION 18
 #endif